Espurna Setup. Going crazy here!

Firstly, I’m new to this MQTT stuff and slowly going mad, so after 3 days of nothing, here I am…

I’m using Sonoff devices with Espurna 1.13.3 running MQTT. The basic protocol is working but I cannot see the status of any test devices. See the screenshot for more.

I must be missing something obvious. Any ideas?

Can you get an MQTT client such as mosquitto_sub or MQTT.FX, connect it to your broker, subscribe to topic # and paste the MQTT messages being sent.


The internal MQTT seems to be completing the transactions just fine, but I;m sure I’m messing up the scripting which is what I was hoping for help on.

As a day 1 noob I expect it’s something simple.

OK. Update. The internal MQTT broker was not responding properly. As I’m so new to this I was trusting it to be working. I moved over to using Windows Mosquitto as a broker and it worked fine straight away.

As I use an Unraid server for MQTT, I then moved to a different MQTT broker as a Docker and that worked too.

I’ve no idea why the internal docker was not working.

Thanks for reading!