Estimote Beacon + OwnTracks issue of proper 'placement'

I’m unsure if it’s an OwnTrack issue, a Beacon issue, or a ‘me’ issue.

I’ve been watching myself on OwnTrack, and it’s properly showing my beacons as red if I’m in them, or blue if I’m not. I’ve tried disabling the beacons to test, but I’m having a peculiar problem.

My setup:

name: 'Home Office'
latitude: 38.7996
longitude: -77.116270
radius: 3
icon: mdi:office

This reflects the Beacon region in OwnTracks whichi is -Home Office. My filename is home_office.yaml
I put a 0 radius in OwnTracks.
If i have the beacon on, I’m reported as

state: Home Office	
battery: 63
friendly_name: Donavin

SOMETIMES - Adding more confusion is sometimes it reports me as

entity_picture: ~~~~
longitude: -77.11627
battery: 62
gps_accuracy: 0
friendly_name: Donavin
latitude: 38.7996

I modified the GPS_Accuracy to 0 as I was testing this to see if it would take effect.

I’ve played with the Beacons and GPS Accuracy for about 2 days and I’m genuinely lost.It’s KIND of working in the sense that Home Office
home office and
home_office are all showing me that they’re in the Home Office, but it’s causing me a lot of automation issues. (Like the lights turning off when one of the devices leave)

It’s kind of a multi-part confusion/complaint/issue.
A) Why is the zone name changing? Is my naming convention wrong for using multiple words? I just prefer it aesthetically, but I could probably use Customize instead of these.
B) Can I bypass OwnTracks, and just use the beacons for tracking? I followed the multiple sections and guides I found about using BLE-Ts with OwnTracks so thought this would work.
C) Is there a script that will more-frequently check OwnTracks for my location? Currently I have to open the map whenever I can tell it’s wrong about my location.

Welcome any advice - Kind of going insane about it.

(Random side-bit: Does anyone know how to get temperature/light sensor readings from Estimote Beacons? Seems it’s impossible without building in their SDK.)

here is what i did:

so far all of my devices are android - but i may try my ipad over next couple of days and see how that works too…
2 zones so far (more on the way).

main “home” zone is set up as a GPS zone with a 75M radius in hass - 100M in owntracks. EDIT - also, i explicitly set up a “home” zone here’s it’s config:

  name: Home
  latitude: xxxxx
  longitude: yyyyy
  radius: 75
  icon: mdi:home

2nd “den” zone set up as a beacon zone and set up with name “-den” in owntracks.

both zones are set to the identical lattitude and longitude in HA

i have 3 ibeacons (vs estimote) in my den (about 12’x12’ room)- with the broadcast power turned down as low as possible - beacon shows it to be a 2 meter range.

here’s the den zone config in HA:

zone 2:
  name: den
  latitude: xxxxx
  longitude: yyyyy
  radius: 1
  passive: true
  icon: mdi:television

now when i enter my den with my android phone, owntracks/HA determine i’m in a beacon zone and my lcoation switches to my 2nd zone.

when i leave the den, out of beacon range, owntracks/HA determine i’m back in home zone.

i plan to add more beacons to other rooms i want to track like this…

this was the post i found in the blog that turned me onto the passive option… read through it…