Etching image to Raspberry Pi 32G card creates 39M card

When I use etcher to flash the image, it reverts the 32G card to a 39.9MB imaged card. How do I expand the OS to support the entire space on the card?

What OS are you using?

I believe its the first option of raspi-config

It is resinos. It is the image provided by HA for the raspberry Pi3.

Yea, have you tried to expand the filesystem, using raspi-config?

Well, it looks like that isn’t happening. I insert the card and boot the Pi and simply get the HA logo and nothing else. It has been sitting for hours with a blank screen. I rebooted and get the same result. I guess I will be troubleshooting a boot issue instead. Once I get it operational I will check out raspi-config.


Sounds to me like the image didn’t get written to the SD card right… What OS did you use to write the image to the card? Might have to re-do that bit.

It wrote it on there. I can see the folders and it does go to a Home Assistant splash screen on boot. It just doesn’t do anything after that. I am running etcher on a Windows 7 Pro system.

Oh, and I see your pic and want to call you Max. Ha ha ha.

Sounds to me like it didn’t write the image correctly. I’m not familiar etcher. Try using Win32DiskImager:

I downloaded resinos-hassio-1.1-raspberrypi3.img.bz2 and extracted the image with 7 zip so I could use Win32Diskimager. It still does the same thing. I am now questioning the image hosted on the Home Assistant Pi3 setup page here:

When you said you see the Home Assistant splash screen on boot, are you looking at the console output, like on a monitor? The instructions mention setting a static IP, and browsing (with a browser) to the link provided. Have you tried that?

Sounds like you need to go to http://hassio.local in your web browser after waiting 30 mins or so for the Pi to download and set up what it has to do. There’s nothing to do on the Raspi itself. You need to access via a browser on another computer.

Also, there’s no need to resize the SD. I’m guessing the partition you can see on windows is just a boot partition and the rest of the OS is on partitions with file systems that windows can’t read.

Ahhhh. I was trying this at work which is why the hassio.local wasn’t working, but it worried me that the hdmi output went blank after the splash screen. I didn’t realize that was normal which is fine since it is simply a server. Setting up a static ip and disregarding the output and boot partitions is what I needed.