Eth0 Problem Raspberry pi 4 Home Assistant

Good afternon,

After try home assitant in a VM following all the steps i had a gratefull result, everything was runing correctly.

But, when i tried to install te Home Assistant SO in my raspberry pi4, i have had problems with what i think it is the ethernet adapter

The main difference between the first case and the second it’s the router because in 1st step with the VM i was in a house and now in an other.
The command line shows this:

I have tried with a raspbian SO, and everithing woks correctly, it seems like an error in the image of the HomeAssistant or something like that, maybe a bad configuration in my raspberry.

Sorry aobut the photo but i can not access by ssh becuase the router doesn`t shows me an ip for the device
Thanks to everyone

You can use fing or similar android (there are ip scanners for iPhone also if you are not using android) app to scan the network and find the IP address of the rpi.
What is the exact problem - all I can see is IP6 not ready - maybe you configured hass or the rpi to work only with IP6 when the router don’t support it - just a guess.

1 Like

Hello masoko
I have tried to serch with ip scaner, the pc software and shows something a Bit strange
Doing a ping to a ip where the software describes it like home asistant apears this


The problem it’s that i dont know why mi raspberry can not conect to the net
I have tried a lot of times with the iso of 64 Bit, and with the 32 Bit that HA gives in the page
Mi raspberry is the 4 of 4gb of ram, im using a 64gb sd
The router suport ipv6 because itngives me the option of disconect it but i have not do it never
Thanks for your reply and help

I have no experience with running home assistant in VM - I run it in a docker container and it is very good - before that I was doing a regular installation directly on raspbian and it was little easier to configure and add custom things but I wanted to learn some docker and tried it - its even better - easier to upgrade change version.
If you have no real reason to use VM go for docker container - it runs really smooth.
What OS do you run behind that VM ?

1 Like

I would like to install the HA with the iso but I will try to install HA in a docker, that would give me the option of use the raspberrry for more than one thing.
Maybe with in desktop raspbian distro and a with a docker of HA, i don’t know if it is possible.

I was traying to install with the ISO because it looks like the easiest way to run it
Thanks for your help

I am not sure how the rpi4 will perform with both the GUI and hass - it depends how many sensors you have and what you do in the GUI - but the docker installation is very easy - you install docker and some libraries with apt get and then one command to load the home assistant container. the good thing is that you can easily install many other things in containers.

1 Like

Hi! I have just make it work.
It was a really stupid issue, the lan cable, which I had already test 1000 times don’t work with the hasso SO, but yes with the raspbian.
I have plug another cable and it start to load the configuration.
Thanks for everything