Eufy Camera Integration

Hi Fuzzy!

Yes, I do stand corrected, and I was not intending on pointing the finger at Eufy as their products are great but ideally (and the motto of HA) is ‘privacy and localization’
In any case, this is not the forum to illicit this sort of discussion and I do admire those that can create these types of addons via the open-source community.

If I can help I am happy to!

2 Likes

I am struggling with getting streaming to work on my 2 T8114 cameras (EufyCam 2). I have RTSP enabled, and have confirmed that it works by connecting to the URL via VLC. I have also called the services for starting RTSP and starting livestream from this integration’s services. I can confirm that this issue remains present in today’s latest code release.

When I look at the camera’s attributes after turning on the livestream, I see this value change:
live_streaming_status: livestream started

But no matter what I do, I always see this:
rtsp_url: null

which I assume is where the problem lies.

Has anyone else run in to similar issues and have any suggestions? Can anyone confirm they have these cameras working?

Can you just click on camera image, it should enable rtsp automatically. What i see from this record, it is live streaming over p2p not rtsp.

No luck. I was previously testing from the entities page, but set up a test page in Lovelace using a picture-glance card.

  - type: picture-glance
    title: Garage
    entities: []
    camera_image: camera.eufy_garage

While I can see an image of the last event, if I click on it, the camera stream just comes up blank:

There is a corresponding message in my log:

2021-07-24 08:47:10 ERROR (stream_worker) [homeassistant.components.stream.worker] Error opening stream None

Considering the rtsp_url shows as null, and the stream report None, I figured they might be related.

Hi
I cant follow anymore
Thats the 6th addon already?
What about the one from @bachya?

This whole thread is so confusing, too many options.
Can someone please update opening post on all the possibilities now please?

How differs this one from the one bachya is making?

1 Like

So you are angry or frustrated because we are trying to improve things? No enforcement or hard strings to pick 6th add-on, you can keep whatever you have now if you are satisfied with it.

Moreover, no one has any kind of responsibility or duty to do what you ask. You are free to reach admins or post owner to update it to include all options.

Lastly;

  • everything started with some python and node js libraries without no home assistant support
  • then we had eufy security mqtt custom integration to have motion/person sensors, battery and latest image, thanks @matijse (GitHub - matijse/eufy-ha-mqtt-bridge: Receive Eufy alerts and thumbnails in Home Assistant via MQTT)
  • then @bropat came up with one complete solution to handle p2p communication with devices and stations, but still no direct home assistant integration
  • then, @bropat came up with iobroker plugin (another self service home automation tool) and people found way to integrate home assistant with iobroker
  • then @bachya started on full home assistant integration, but he is looking for complete, core integration solution.
  • while he was working on neat solution, i just developed a working but not good (in terms of software development perspective) solution and published it but it was requiring users to setup a docker / node js server manually (Eufy Security Integration)
  • i reached another step and developed an add-on (please do not confuse add-ons with custom integrations) and improved existing integration to support more devices. I have placed multiple warnings that this is half baked solution. (Eufy Security Integration)

Now, please take the lead and make everyone’s life easier.

7 Likes

Hi i think you misunderstand me.
I’m not angry at all, i can only encourage people who are working on this voluntarely and even in their free time. Which i appreciate a lot ! Thank you.

The only thing tht “bothers” me, is that i get lost in all the options…

Thanks for the summary now…
(i thought there were more options too (there was a custom integration also, but nevermind that)

So your last add-on… theres no doorbell support yet, right?

Could your addon be the one for @bachya?
Maybe you guys can share work?
Or am i totally lost there

TBH you can just read through the thread and get all your questions answered. I have fuatakgun’s add-on working with my 2k battery doorbell - well, the motion and people detection works, as does the doorbell button press, and the still picture of last event. I can start a live stream but it makes my home assistant fall over (which is fine by me, now at least I can hang other automations off of someone being at the front door and that was my main purpose)
Installation is very clearly documented and pretty straight forward, so why don’t you just give it a try? Just follow the readme link from Eufy Camera Integration - #1297 by fuatakgun

1 Like

I will try it thanks

What automations do you have based on someone being at front door.
The older integrations/addons didnt work well for me showing last event picture, mostly there was no pic
I hope this one is better

Trying it now

My wife is immunocompromised so very vulnerable to covid even after 2 jabs. Our delivery people know to put our deliveries in the foyer. Since covid is airborne, and delta is prevalent here, and simply walking through someone’s breath who has delta is known to infect people, I run a simple timer turning a light red for the next 20 minutes so our foyer can air out (windows open at all times). Once the light goes back to normal I know I can go and get the delivery relatively safely. This reduces our waste by about 4 plastic face masks a day, and our cost too of course. (We use ffp2 and ffp3 masks since the blue ones offer very little protection as they do not make a good enough seal.)

2 Likes

Regarding to freezing home assistant instance, can you try with downgrading quality settings for you camera? That should at least give some space and time for your server to keep up :slight_smile:

I will be back from weekend vacation tomorrow and will definitely improve/fix this.

1 Like

Mmmm :-/
After step 4 filling in credentials in configuration tab, i’m watching the logs but nothing is there
When i look into system log i see errors:

21-07-25 14:52:42 WARNING (MainThread) [supervisor.misc.tasks] Watchdog found a problem with 3a26b21d_eufy_security_addon!
21-07-25 14:52:43 INFO (SyncWorker_5) [supervisor.docker.interface] Cleaning addon_3a26b21d_eufy_security_addon application
21-07-25 14:52:44 WARNING (SyncWorker_6) [supervisor.docker.interface] Can’t grep logs from bropat/eufy-security-ws: 404 Client Error for http+docker://localhost/v1.41/containers/7e4e890974b9385bda15302761dd5cb32d56d5678def20f8835b2ecc8a3ec714/json: Not Found (“No such container: 7e4e890974b9385bda15302761dd5cb32d56d5678def20f8835b2ecc8a3ec714”)
21-07-25 14:52:49 INFO (SyncWorker_5) [supervisor.docker.addon] Starting Docker add-on bropat/eufy-security-ws with version latest
21-07-25 14:53:20 WARNING (MainThread) [supervisor.misc.tasks] Watchdog found a problem with 3a26b21d_eufy_security_addon!
21-07-25 14:53:21 INFO (SyncWorker_3) [supervisor.docker.interface] Cleaning addon_3a26b21d_eufy_security_addon application
21-07-25 14:53:26 INFO (SyncWorker_3) [supervisor.docker.addon] Starting Docker add-on bropat/eufy-security-ws with version latest

I tried restarting but no good

As a starting point;

  • try with disabling watchdog in supervisor settings doe this addon. On there might be some logs in supervisor or core why this is happening.
  • if this doesn’t work, try with manual running the docker using command from README file.

We can find where to focus.

Ok, i thought it would be cause of the country i filled in

I filled in “Belgium”, now i changed to “BE” , i now get logs, stupid of me

eufy_security_addon
2021-07-25 13:06:51.913 INFO Eufy Security server listening on port 3000
x
2021-07-25 13:07:04.282 INFO Push notification connection successfully established

I’m continuing now

I need to sync with @bachya before answering this and he is not available nowadays because of family topics.

Developing an integration for home assistant has a well very defined list of steps which would enable final integration to me embedded inside core.

OR, you are a lazy developer like me and you start backwards and aim to have a basic running stuff, rather than following best practices.

bachya is following first way, i envy of him but i am lazy and i am following other way around. I will definitely contribute his solution or we can even use existing integration for his work. Nothing is clear as of now.

Even though we merge or diverge in the future, both ways should be well embraced and encouraged right?

4 Likes

I agree totally
:slight_smile:

You guys rock!
I completed your integration/addon now, and i’m getting 2 devices now (doorbell and camera) which is correct
Superb !

Will see if the doorbell works better now :slight_smile: Thanks already for the hard work !
Do you use automations inside HA?
I’m eager to know what automations you guys use then, perhaps we or someone else can benefit from it too

I will do this if it helps you? For myself, I am happy with the last event pic and the motion sensors and will do any live streaming via the eufy app. That does remind me, I can use the eufy app to give some canned responses to the person ringing the doorbell. Do you know if this is supported in bropat’s library?

Absolutely! thank you for all your work on this, much appreciated!

How do your guys lovelace code look like?

I added this:

- type: picture-glance
        title: Voordeur
        entities: []
        camera_image: camera.deurbel

However i don’t see if motion is detected, or its streaming.;
When i click on it, the first 3 times i could see live picture
Now , it doesnt work anymore and i didnt change anything

Also is it normal i cant stream the camera from the doorbell?

I have exactly the same problem. It worked fine for a few minutes and since then I have no more images / streaming. My image remains permanently in “broadcast in progress”.
I tried to uninstall everything and reinstall everything, it’s still the same.