Eufy Security Integration

Being truthful I’m not entirely sure now, I followed a guide quite some time ago and that was required if running HA Core. I believe it was something to do with RTSP and WebRTC

Hi, I have been using the eufy security add on for a while now for my eufy dual cam doorbell. I have just added a new security camera s340 solocam. Have tried reloading the integration and restarting HA but it does not show up. It is supported. Do I need to do something specific to add a second device to the integration? thanks

I figured it out myself. There is an option in the Eufy app to share your devices. Just needed to check the box next to the new camera and about 5 mins later it appeared in HA after an integration reload.

Hi,

I use the webrtc card and I have “can’t get get url for the camera…” .
When I start the camera, i have to refresh the page to see the streaming.

Have you a solution ? I have eufy 2c pro camera.

Same cameras - same problem!

I ended up writing a script, that

  • starts the stream
  • waits for one second
  • refreshes the page automatically :slight_smile:

It was my idea but I wanted to avoid that. Do you have the script?

Has anyone had any luck in taking a snapshot using the Eufy s340 solo camera?

Thanks, I tried it but I don’t like it.
I tryied another solution that works :

  • Create an input boolean
  • Switch the status when camera stream or not
  • Use the boolean with conditional card
alias: Rafraichissement caméra cour
description: >-
  Permet de rafraichir la caméra lorsque la lecture est lancée depuis le
  dashboard. Sinon il faut recharger la page pour avoir l'affichage
trigger:
  - platform: state
    entity_id:
      - camera.camera_cour
    to: idle
  - platform: state
    entity_id:
      - camera.camera_cour
    to: streaming
condition: []
action:
  - delay:
      hours: 0
      minutes: 0
      seconds: 5
      milliseconds: 0
  - if:
      - condition: state
        entity_id: camera.camera_cour
        state: streaming
    then:
      - service: input_boolean.turn_on
        data: {}
        target:
          entity_id: input_boolean.rafraichir_la_camera_cour
    else:
      - service: input_boolean.turn_off
        metadata: {}
        data: {}
        target:
          entity_id: input_boolean.rafraichir_la_camera_cour
mode: single

1 Like

For me it worked pretty much straight away, but the stream is SO SLOW!

I have two other Eufy cams, an Indoor 2K Pan Tilt and a regular Indoor 2K cam. Both have the RTSP stream enabled and are showing in Home Assistant perfectly with a custom:webrtc-camera card. But fore some reason this Floodlight E340 cam is ridiculously slow. The feed only updates every 4-5 seconds.

Despite the fact that this camera has the best WiFi reception of all. Anyone with an idea what could cause this?

Edit: I’m now just noticing that the stream provider is P2P rather that RTSP. All other cameras are RTSP. But no idea how to change that, because the RTSP stream is activated in the camera settings

Today, I cannot disable alarm with script, I have the following error :
Erreur : AlarmoBaseEntity.async_alarm_disarm() takes 1 positional argument but 2 were given

Have you ?

Hello Eufy users! :wave:

Does integration work properly with SoloCam S220? I’m considering buying the S220 model. What are the options for this model? Does it only send screenshots when an incident is detected and sending a screenshot on request (so as not to drain battery).

Thanks!

Hi - i have Eufy T8160 cameras. I can see a still image in HA after installing the add on, the HACS integration and then the HA integration - but when I do this, i get “Can’t get URL for camera.backyard”

type: custom:webrtc-camera
entity: camera.backyard

Any ideas?