Eurom E-convect WiFi

Hi, I’m looking for this airco (Coolperfect 180 wifi). Did you get it connected to Hassio?

Kind regards, Eltjo

Hi, I am considering buying an E-comvect. Is the HA integration still reliable?

I haven’t had mine active for quite a while now, I’m more interested if someone has managed to flash the firmware and use tasmota to control it instead.

Hi Eltjo,

I am thinking about buying a similar model, can you tell me if you managed to get it working in HA?


Hi Jose,

I haven’t bought this unit, so no I personally didn’t get it connected to Hassio. My (cheaper) work around is that I have now a normal fan connected to a smart plug. I’ve made an automation with this in combination with a temp sensor in the room and the outside temperature. (If room temperature is > 22 °C AND outside temperature is < 22 °C I get a Telegram message with options to start the fan for 1 hour (or 2, 4, 8 hours).

Long story short, maybe you can start the unit with a smart plug?

Good idea! I need to think about it.
Thanks Eltjo for coming back.

Hi Nicholas,

I am curious to know if you were brave enough to try to flash it with tasmota or are you using tuya?



No it’s not flashed, I’ve asked around to see if anyone else did but no results yet.
If it works I will flash it for sure but I have no info on it what so ever.


does anyone knows how to factory reset this thing? since the new app release, I can simply not connect nor reconfigure.


Hi all,

I moved my “Eurom ceramic heater 2000 wifi” from Euron app to official Tuya app.
Then, I added Tuya to HA using the integration page. It all worked, but the device is not found.
I tried restarting HA and forcing an update using the service. Both no luck.
Any ideas?

@Pedro_Santos mine resetted by deleting it from the Euron app. After that I also held the wifi led 5 seconds, so it started blinking.

Is there somebody who has flash his eurom heater with esphome or tasmota?

It seems my device is not capable of being controlled by 3rd party. The same happens in Google Home. When adding automations in tuya they are added to HA.

I just flashed my Eurom Alutherm heater with Tasmota.

First step was to look what chip they used inside, so I opened the device and found the tywe1s tuya chip (it’s a esp8266). The heater is controlled by the tywe1s with a serial connection (tuya-mcu).

To flash I used the tuya convert (no soldering needed, it uses the ota update system):

To configure Tasmota I also used: to help identify the dpid’s.

I can now control or view with homeassistant:

  • controlPower (on/off)
  • view the requested temperature
  • view the measured temperature

Still not working in HA:

  • control the requested temperature
  • control the ECO mode
  • change the heating power (low/mid/high)

I think i need to set this device as a climate controller, but this is not supported in HA Tasmota.


Lemme try that again.

I have two Eurom Sani-Wall-Heat 2000 Wifi, I just pulled both apart and deleted the annoying beep.

I added them to the app and I can see them in my developer account on Tuya IOT but they don’t appear in the devices list of the Tuya integration in HA, or tuyacli etc…
So these devices are not supported in their API. I already sent an email to their API support folk.

Here are some snaps I took from the tuya boards, seeing as you already got them trough the Tasmota wringer but are unable to actually perform any climate functions I’m hesitant to follow suit and converting them to Tasmota via OTA without a clear back to factory settings method.

Doubting what to do next… I could go ahead and flash them or I could try to swap out the tuya board for a custom nodemcu.

If you flash with tuya convert, then you get also a backup file. So you can try and go back to the previous firmware.

I also have an Alutherm 2000 heater, nice to know that could be converted too.

I tried to do the tuyaconvert on a euro wifi wall design heater but that did not work,…
I’m tempted to just solder to it and do it that way

Took a while but I flashed it with tasmota after I could be arsed to setup a Pi4 and a Nodemcu to do tuyaconvert.
So results so far : it’s got basic tasmota on it, it connects to the wifi and I can get to the webserver.

All the other controls; being IR command or on device buttons continue to work; that’s excellent. Display works too, good.

I just need to figure out how to configure tasmota to switch it on and off based upon motion detections/timeouts.

Did you use the tasmota.lite bin? And did you used a template to setup the heater in tasmota?. I have a 800xs and also wants to flash it. But i need to know if the thermostat options are still available after flashing

I used tuyaconvert, I think it’s the full build.
That said, I’ve since reverted to the old firmware. I could not get it to work with my specific heater, the tuyaboard doesn’t use tuyamcu to talk to the heater mainboard, it’s rx/tx but the protocol is unknown and I left it at that as the thing needs to heat during winter.
Come summer I might tinker with it again, but not likely.

Was an absolute pain to get the old firmware back on there, I actually had to dump the firmware of a still original second heater to get the converted one working. So that’s soldering twice.

Just added the Eurom 800xs heater. However im only getting a on/off device nothing more.