Eurom E-convect WiFi


#1

Hi,

I’m considering buying a small heater for one of the bedrooms. I found this one: http://www.eurom.nl/nl/producten/verwarming/convectorkachels/i/168-convectorkachels/1597-e-convect-wifi. It supports remote control over WiFi using their app: https://play.google.com/store/apps/details?id=com.eurom.smart. I couldn’t find any way to interact with it using an api. Any suggestions how to connect it to HA?


Eurom Heater
#2

I got a reference to this API description from the manufacturer: https://docs.tuya.com/en/cloudapi


#3

Hey!

Did you ever get somewhere with the provided API?
I am currently setting up Home Assistant for the first time and it will be the heart in my home alongside all of my Google Home devices.
I have one of those Convectors in our bedroom and have been trying to get some info about the API for it.
I’m gonna have a look at the link you provided when I have the time for it, looks promising :slight_smile:


#4

Not yet, but … ''winter is coming"… so perhaps somewhere later this season, when I really get annoyed by the app :slight_smile:

Just saw this link: https://github.com/codetheweb/tuyapi


#5

I have minimum control using the the TuyaSmart app and Hass Tuya component for my Eurom Airco.
The Airco is recognized in Hass and i can switch it on and off.
Setting the temperature (climate platform) is not working.
Maybe the heater got better support?


#6

Yeah winter is coming and it would be cool to get the heaters to work properly.
Just got my Home Assistant up and running this Wednesday so now it’s time to do some basic configuring :smiley:


#7

Good to hear that there is some control at least, I’ll check if it works with the heater during the weekend.
On and off control along with temp would be enough at this point, keeping my fingers crossed.


#8

So minor update, found out that Hass supports the tuya component so tried to add that in the configuration file.
Well that didn’t work, told me that the username and password was incorrect, so back to the drawing board and reset my password but still the same issue.

Took a step back and found out that the app and account I used was in fact a spin off of the Tuya Smart app and not the same at all. So I signed up for a real Tuya account and installed the app.

So now my credentials are accepted and the Tuya component is added with no errors, keeping my fingers crossed that I can add my E-convect WiFi when I get home. Took a quick peek at the setup process for it and it’s the same as in the Eurom Smart app so it should work.

I’ll post back here as soon as I have some results from all this!


#9

So it’s all up and running perfectly, scrapped the old Eurom app for the heater and added my heater to the Tuya app instead. Restarted Hass and woila! Master Bedroom Heater was present in the entities list right away.
Next I simply copied the entitiy id ‘climate.yaddayadda’ and added it to the Master Bedroom group and now I have a nice heater control with graph and full control over the heater.

Damn I’m impressed with Home Assistant!

Final step is to add an automation for my schedule and let HA take control over my bedroom heating.


#10

@Nikorasu69 Thanks, that strategy also worked for me! Just added an automation to toggle my heater on/off using a xiaomi switch. Next step: turn off the heater if there is no activity in the room for more than 30m


#11

Awesome mate!

The one thing I have problem with right now is that the E-Convect drops the connection to the WiFi which is a real pain, I’m seriously thinking about adding a wall plug to automate a hard reset.
To clarify, this is not a problem with home assistant but the hardware itself. It did the same thing when running the Eurom app, suddenly the convector wouldn’t respond to either the power on/off commands and the schedule would fail.

It’s too bad, because the heater works real damn good to heat up our bedroom.


#12

Bringing this one to live for a small update.
My E-convect WiFi actually works really good now and the network drop off has not been present for a couple of weeks.
I did get a firmware update for the device itself but that didn’t seem to fix anything, perhaps it’s a combo of things.
Anyway, real happy about it all :smile:


#13

I have the same heater, added it to the tuya app, never bothered with the Eurom app. Has been hooked up nicely to Homeassistant as well. But a couple of weeks ago the tuya app updated and it was no longer possible to control the finer things like swing/mode. Only on/off. Homeassistant continued to work, temperature and on/off. But not mode.
Anyone else with this problem or is it just me?


#14

Probably not related but even though my automation works and it turns on as it should, the entity info still shows the heater as being turned ‘off’. This used to work properly until an earlier firmware update.

As a side note, I watched DrZzz livestream yesterday and got real exited. Apparently there is a way to flash Tasmota into Tuya devices using OTE, now the stream was only about the cheap Tuya wall plugs but it would be awesome if someone made this possible for other Tuya devices as well so that we can take full control over them.


#15

How did you do this?

I’ve got https://www.eurom.nl/nl/producten/verwarming/convectorkachels/i/168-convectorkachels/1614-alutherm-1001

Somehow tuya can’t connect to the heater :confused:


#16

Never mind, a few tries later, and actually putting my phone on the heater during connecting it works…


#17

Glad you worked it out!
If you don’t mind, feel free to report back if you have similar issues with the heater dropping the connections at times.


#18

I do, it’s not reliable at all. So right now I have a multisensor *bruh to measure temp.

Setting the target temp does not work either :confused: