Eve devices over thread


I cannot get a couple of Eve Thermos to connect to HA via Thread.

The setup is:

  • HA (2023.3.1) running in a Docker container
  • Multiple HomePod Minis (all running 16.3.2)
  • Multiple Eve Thermo devices of the latest generation

If I set them up via HomeKit, they are first connected via bluetooth, and soon switch to Thread. As far as I can tell, this is working as expected.

Following this documentation and this thread, I removed the Thermo from HomeKit. This immediately triggers a “new device found”-notification in HA. If I then try to configure it, I get “Pairing attempt failed with an unhandled exception”, and logs leading me to a

What I tried so far:

  • Keep the device awake by pressing buttons on it
  • Rebooting the device by removing the batteries and wait for half a minute. The device does something after reinserting the batteries, but I get the same error message.
  • Reseting the device. This allows me to connect it to HA, but only via Bluetooth (side note: I’m positively surprised about the range of Bluetooth in this building …).

Using bluetoothctl on the command line (outside of the container), I also tried to trace the device. It is discoverable as long as it was not connected to HomeKit. After removal (without reset) from HomeKit, I can no longer connect to it via Bluetooth, only after reseting it appears again.

Any ideas what I could try next?

1 Like

Is your HA on the same VLAN/subnet as the border router (Homepod)? The HA thread documentation says it must be and I can confirm thread will not work even with Avahi pushing mDNS across VLAN’s.

If you can’t pair your device with HA, perhaps ensure that the device is reset before adding it to your iOS device and removing it to repair to HA and ensure you comply with the first point. Also make sure you’re on the same VLAN/subnet that HA will use when you pair with iOS. Apparent;ly you are putting the device on the appropriate subnet when you pair with iOS; that subnet must be where HA and the Apple border router (HomePod) are located.

As an aside I’ve seen a lot of problems with HA thread dropping devices once paired after a few hours. There is an open ticket but I don’t see much being done there just yet. I ended up putting my thread devices on the Apple side and integrating with HA input_booleans but that’s painful!

Thanks, but it’s definitely on the same subnet.

I tried resetting the device before adding to HA, but then they don’t have the credentials for the thread network.

@nilsreiter Have you ever found a solution for adding Eve Thermo devices to thread? I’m experiencing the same issue, when removing the devices from Apple Homekit and trying to add them to HA I’m told that the device is already paired and needs to be reset – and when resetting it, I can add it to HA, but it will only connect via Bluetooth.

1 Like

I never got it to work with the HomePods, but it works ok with the SkyConnect USB stick in the multi protocol (zigbee/thread) variant.

After creating a new thread network with a SkyConnect dongle on HA I managed to re-pair all Eve devices. My Homepod Mini now has its own network, which is unused by other devices.

Yes, as far as I know, this is how it is at the moment.

Are you still facing issues with your Eve devices on Thread?

My Eve devices have been pretty stable as of late. I use Apple border routers and Eve with Thread/Matter. Double pairing to HA and HomeKit is routine. I spread some Eve Energy around the house to help coverage or the smaller/distant sensors seemed a bit flaky.

Yes, but not too serious. Some devices are sometimes, without any observable patterns, unavailable. Most of the time, they reconnect after some time.

The setup is:

  • HomeAssistant yellow, using multi protocol (Thread/Zigbee)
  • 4 HomePod Minis form the Thread network
  • HA joined the network.
  • Not using matter at the moment, but add Eve devices as HomeKit device
1 Like

My set-up is similar to yours and am facing the Thread devices disconnecting often.

Actually, I just noticed that 2024.2 made things much more stable. Haven’t had an unavailability for weeks.

Since 2024.3 my Eve Aqua is going crazy again.

@codyc1515 : Hi, how did you get the EVE Aqua integrated into HA? I have tried the way as described in Homekit Device integration (delete it from Apple Home and HA discovers it) but can’t get HA to accept the code of the device

I would be keen to work out how to connect. my Eve Aqua device to HA. Mine is still on my Apple HomeKit install, should I remove and add directly to the thread service on HA?

I have not been able to move my EVE Aqua (3 of them) to HA.

Here ist he explanation I have been given:

I have created a Helper Toggle for each Aqua in HA, which is passed to Apple Homekit thru the Homekit Integration. I let HA decided when water is needed and set the Toggle to „On“. Apple Homekit will then activate the time plan for the given EVE Aqua. (Btw, the latter can also be done in the EVE App)

Hope this helps.