eWelink Integration

Hi guys,
I purchased one of these wifi switches https://www.amazon.co.uk/gp/product/B07DS44LXJ/ref=ppx_yo_dt_b_asin_title_o02_s00?ie=UTF8&psc=1 and looking to get it hooked into HA but cannot find the integration page for it.
Are there any custom modules or anything like that I can install to get it to show up in HA?

have you seen this link?
I am using it for one of my switch that I can’t be bothered to flash to Tasmota. It works really well

1 Like

Thanks for that, just tried it there with this config added to my config.yaml:

  username: !secret ewelink_username
  password: !secret ewelink_password

And the 3 files as instructed in the github page but HA fails to start with that config, any idea?

Assuming you put the files in the correct place as per the link,it should work.

Here is my config:

  username: !secret sonoff_user
  password: !secret sonoff_psw
  scan_interval: 60 
  grace_period: 600 
  api_region: 'eu' 
  entity_prefix: True 
  debug: False

Have you tried to first install the file without any config then restart? does it start?

if it does add the config and restart again and see what happens

Got it in the end just by doing that and it works great, thanks

1 Like

Good news!

I get this Component error: sonoff - Integration ‘sonoff’ not found also tried it with just the sonoff: with nothing else

  username: my email
  password: pass

Did you install the custom component and restarted HA after that ?

im new user and feel so sad that i didnt get it work, please help

where we install the file? im new in this

Download the github repository and copy the sonoff folder to conf/custom_components/

Or, if you are using the Home Assistant in a Raspbian/Docker, use the folder /usr/share/hassio/homeassistant/custom_components/

can’t rememeber if the docs mention it, but might be worth setting up a second ewelink account - one for HA and one for your mobile. bit of a work around to the grace period although I find it helps more for testing of automations without the 10m waits

Hi Guys,

This works great for my CEMIG breaker DIN rail switch, it recognizes the switch and creates a switch.sonoffXXX device, however, I cannot seem to find it in my devices list in the automations.
Any idea how to tackle this? If I open the switch details in the states tab of HASSIO I can operate the switch just fine, so it all works well, but how to get it in the devices list.

I have the same issue with the TUYA integration, works well, can create cards, see them in states but I am not able to list them under devices in automations.

All my Shelly and Tasmota devices show up just fine, also my MQTT devices are visible… Just not these two integrations.

Not all integrations show their devices in device list. It depends on the integration.

Any way to add them manually?

Not that I know


Im trying in ernest to get this to work.

Ive got as far as added the configuration, added the .py files.

restarting then tells me im using the sonoff “You are using a custom integration for sonoff which has not been tested by Home Assistant.”

so, im assuming its working in homeassistant. but how do i add my sonoff devices ?



Have you checked in your device list that a new switch has not appeared?

something like switch.sonoff…

yeah, nothing appears related to sonoff.

i am totally stuck !

You should not search under devices, but under entities.

1 Like