eWeLink Smart Home 1.2.2 upgrade failing

Hey everyone!
Has anyone experienced any upgrade issues when trying to upgrade the eWelink integration in HA from 1.2.1 to 1.2.2? How did you solve it? Any advice for me?
See my error message here: “The command ‘/bin/sh -c yarn --production’ returned a non-zero code: 1”
image

I Have the same issue on two homeassistant instances

Same issue installing for the first time the component to Home Assistant… v1.2.2

same issue here. First time trying to install directly V 1.2.2

Hello everybody. Same problem for me. Home Assistant Blue

Me ha ocurrido el mismo problema con las ultimas actualizaciones de Home Assistant. Si alguien sabe como resolverlo estaremos todos agradecidos.

Unfortunately I am not able to solve this by myself. Very grateful to whom can help!

It seems 1.2.3 is the solution. Just tried it and it worked.

I had uninstalled 1.2.1 in an attempt to move to 1.2.2 via a fresh installation but that had the same issue as the upgrade.

Fortunately 1.2.3 was released moments/couple hours ago and that has worked fine for me.

Thanks ZavyZavy! However, I have no idea how to uninstall ver. 1.2.2.
Is it a requirement? Sufficient to retry installation with the new version “over” the 1.2.2?
Many thanks again!

Confirmed it installs now. Just retry installation, version 1.2.3 will install replacing 1.2.2
Thanks again.

Confirmado. La version 1.2.3. de eweliink smart home, vuelve a funcionar correctamente. Problema solucionado.