Exception caused by Waze travel Time sensor

I was tinkering with some automations and restarted Home Assistant. Now I am consistently getting the following error when trying to start:

2018-06-17 13:39:12 INFO (MainThread) [homeassistant.core] Bus:Handling <Event service_executed[L]: 
2018-06-17 13:39:13 ERROR (MainThread) [homeassistant.core] Error doing job: Exception in callback 
<function _chain_future.<locals>._set_state at 0x7f9ae286aea0>
Traceback (most recent call last):
  File "uvloop/cbhandles.pyx", line 64, in uvloop.loop.Handle._run
  File "/usr/local/lib/python3.6/asyncio/futures.py", line 399, in _set_state
    _copy_future_state(other, future)
  File "/usr/local/lib/python3.6/asyncio/futures.py", line 375, in _copy_future_state
TypeError: StopIteration interacts badly with generators and cannot be raised into a Future

After this error Home Assistant fails to start up. I am running Home Assistant in Docker on an Ubuntu server.

  • I have tried updating to the latest version (0.71.0).
  • I have also tried rolling back the configuration to a previously known good state without success.
  • I have rebooted the whole server

I do not know what could be causing this problem. Any pointers would be very much appreciated.

UPDATE: I have tracked it down to the waze travel time sensor. As soon as this sensor is disabled the error disappears and Home Assistant is starting up.

Waze travel time sensor is broken at the moment. Something changed on the waze url side and the header that WazeRouteCalculator used is now bad. All versions of the waze component will be broken until the WazeRouteCalculator is updated in HA.

If you are using hassbian, here is a way to update it:

1 Like