Experia Box v10 Device Tracker (KPN, Telfort)

After an extensive search on google for a device tracker for the Experia Box V10, I arrived at the conclusion that this integration did not exist. Thus I have created it. Based on the script created by MvdB (Device tracker for Arcadyan VGV7519 router (Experia Box V8)), I changed the requests that are being performed to match those that are necessary for the ZTE router that KPN and Telfort are currently supplying to customers.

The project can be found here:

I hope this is useful to some of you.

6 Likes

Thanks!! This is exactly what I’ve been looking for. I’ve been using nmap as a workaround.

I tried your script, but it gives an error:

Error doing job: Task exception was never retrieved
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/asyncio/tasks.py", line 180, in _step
    result = coro.send(None)
  File "/usr/src/app/homeassistant/components/device_tracker/__init__.py", line 738, in async_device_tracker_scan
    found_devices = yield from scanner.async_scan_devices()
AttributeError: 'ZteH369ADeviceScanner' object has no attribute 'async_scan_devices'

The script does access the router, because if I try to log in it says that another user is currently logged on, however I guess it doesn’t report back to homeassistant.
I run homeassistant in Docker on a QNAP NAS. I tried restarting and reinstalling homeassistant, but no luck so far.

Hi Thys,

I’ve just updated the script. Noticed I hadn’t saved the latest version of the file. Try again with the new version, that should work for you!

As far as the router goes - that’s the behaviour I would expect. If you need to access the router for some reason, you can also safely tell the interface to log the other user off. This won’t get in the way of presence detection.

1 Like

Thanks a lot, it works now.

Works great. Home is almost instant and Away after 2-3 minutes.

Seems to work however after using the script in Hass.io it’s impossible to get in the webbased admin of the router because of the Admin is always logged in inside Hass.io.

Any suggestions how to fix this? First thought was creating an extra user on the router however that’s impossible on the Experiabox V10.

As far as the router goes - that’s the behaviour I would expect. If you need to access the router for some reason, you can also safely tell the interface to log the other user off. This won’t get in the way of presence detection.

Well that’s the issue, if i tell the router to log of the current logged in admin user it doesn’t do a thing. I can’t get into the experiabox anymore as long as the device tracker is running. Solution for now is to comment the device tracker config, reboot hassio and then log in to the router but it’s far from ideal.

That’s odd - on my interface I can simply select the user that’s logged in, with the radio button in front of it, and force the interface to log them off. I’ll see at some point this week if I can update the script to log the user off properly. It seems to be ignoring the last request it makes to the router.

I’ve just updated the script to resolve this issue. Unless you time your router configuration session at exactly the same time as the device tracker checks your status, you now won’t get the notification that someone is already logged in on the router. Update your script, restart home assistant and let me know if it works for you!

Today I installed two “Experia Wifi” access points, which KPN gives out for free if your Wifi isn’t sufficient (can be tested through the wifi tuner: https://www.kpn.com/internet/wifi/tuner.htm). Unfortunately these Access points turn off the Wifi of the V10 and all devices are shown as LAN devices. Is there any way to track them through this device tracker?

Hi Barry,

Unfortunately these access points are not currently supported by this plugin. Since I don’t have these access points myself I’m, as of right now, also unable to help in developing this functionality.

I’m open to assist if someone picks this up though.

Hi Sjaak, I managed to track the wifi devices through the list of LAN clients (as they are listed there) by changing AccessMode=WLAN to AccessMode=LAN in the data-url in experiaboxv10.py.
Unfortunately after turning the wifi connection off on my phone the phone still stays listed in the LAN clients list on the Experiabox. I thought lowering the DHCP lease 60 second would be a solution for that, but no. The device stays listed. Any idea on this?

Should the script work while using a Experia Boxv10A? (VRV9517)

i’m getting an error (i’m quite new to this).

Unable to load /config/known_devices.yaml: Config file not found: /config/known_devices.yaml

do i need to add anything in experiaboxv10.py?

Hi BarryMorsel,

I’m going to assume that this is caused by the router displaying the registered rather than the active LAN devices. My first thought would be that you need to take the list of WiFi devices from these access points instead of from your router.

@Maur1ce
I haven’t tested, but please configure it and let us know if it works. I don’t have one of these boxes myself to test with.

@ruddie
That error seems to be something related to hassio. Could you include the logs that are generated upon boot? You should be able to find them in the “Info” panel of Hassio.local

Yup, I noticed. I tried to alter the v8 code a bit, but I am a little bit stuck. Maybe you can help out a bit? :slight_smile:

I’ve just tried it with the V10A. It gives no errors but I havn’t got it to track my phone just yet. It added my KPN videobox to the known_devices while i had ‘track_new_devices: false’.

I’m going to play with this some more to see if I can make it to work. Or does anyone have the solution?

Worked perfectly fine for me until the latest update to hassio version 0.92.0.

Devices stay not_home but are connected to the network.

Validating the config produces the following error: “Integration experiaboxv10 not found when trying to verify its device_tracker platform.”

Same here :confused: