Experimenting with Tasmota and HA, need some help


I tried to flush one of my Shelly 1L’s with tasmota and set it up working with mqtt in HA (mosquitto).
It does not work and I think i mixed things up.
I defined a topic and prefix in tasmota device.

My situation right now is:

  1. The device is picked up by tasmota integration. But then its entities status is “unavailable”.
  2. I tried manually adding the switch in configuration.yaml as I saw in several places on the internet. This added another entity but it was unavailable too.
  3. I can see in mwtt that there are two topics, one is the topic I configured in the tasmota device (lights/backyaerd_light) and the other is “tasmota” and beneath it there is a generated name.
    Both topics contain valid messages such as device status, version and so on.
    It seems like the device itself and the tasmota integration are trying to work simultaniously on two different topics.

Which way to go ? How to configure it so it will work like a normal switch ? There are guides and posts on the internet displaying both ways.



Hmmm first try to control the tasmotized unit directly by MQTT Explorer and confirm that unit responds/replies as expected to manual commands.
This is also a good way to learn how exactly MQTT messages work…

Once you control MQTT, next step is to hook it up to HA (also here you can monitor exactly what goes on by letting MQTT Explorer listen along :wink: