Extended wifi connections and different IP addresses, is there a way for me to view the devices?

I’m not sure where I should post this on the forum so Admin please feel free to move it.
Had a quick look to see if this was addressed but I didn’t find anything.

I live in a wooden house and have thick wooden walls, and as a result I have to use wifi extenders, however I noticed that the Google Nest Pucks are using a different IP address to my main network and so I can’t see the devices on that other network, is there a simple way to solve this??

This is normal. Why do you have multiple networks?
A wood frame house is the best for WiFi as the wood had minimal effect on the WiFi signal.
What are the IPs?

Might not be true.
WiFi effect is diminished by liquid and wood frame houses can at times contain a lot of moisture compared to concrete.
Concrete can contain iron bars in order to reinforce it, but in one storage houses this might not be the case or at least it can be a very low number.

Is it an internal-only IPv4 address you see, like 192.168.x.x or 10…x.x.x or 172.x.x.x?
And is your normal network one of those too?

Or are you seeing an IPv6 address, where it is 4 hexadecimal numbers and then split by colons?

Its strange you also mentioned here as in my enquiry on the other thread about multiple networks, why is it not possible to have multiple networks? Or are you trying to say HA can only detect devices within the same network having the IP range of address as it is in?

Just as with the author of this thread informed he extends his network using extenders and these came with its DHCP servers and hosting clients within its connection hence multiple networks.

There are others like myself who wish to separate networks for whatever reasons best known to ourselves, be it security or ease of management etc. and multiple network or Vlans are created for this reason, so in using HA it gets hampered because it does not seem to be able “cross” networks.

If HA cannot do multiple network so then just say so, by saying “why do you have multiple network” does not help thank you.

Which Google devices are you referring to? It could be that they might have created their own internal mesh network to talk to each other like the smoke alarms do.

I have a bunch of Google devices, smoke alarms, hub max, thermostats, cctv and they all sit on the subnet I’ve told them to, via assigning them static ip’s within my router.

Maybe you have multiple devices trying to be dhcp servers causing a conflict, maybe check our the WiFi extenders settings as that’s the first place I’d look to see if they are trying to dhcp, then troubleshoot from there.

Can i check with you if your HA is on the same subnet as those Google devices? are they detectable by HA (if its on a different IP address range) Thanks


Every device on my network has a static IP in the 192.168.0.X range, wired or WiFi, each gets a static IP, it just makes it so much easier for me to maintain.

Thank you for confirming they are all on the same IP range.

If you’re having issues with HA discovering Google devices, have you done the whole ‘become a developer’ bit and made your own app thing to make the Google nest integration work, yet?

I’m the OP, the devices are on the same subnet, however the first google puck I set up always defines itself as a router rather than a bridge and then defines another network ip address for everything that attaches itself to that puck. So if the main network is 194.180.50… then the first google puck decides to be on 194.180.86… and then HA can’t see the devices attached to that network

I think that’s cleared it up, the google puck (I won’t call them nest as they are way to old for that!) are forming a mesh system and so they form their own internal network. I guess I could force the first puck to be an extender but then that defeats the object of the mesh system and as I already have TP-Link extenders it would just be doubling everything up. The system as a whole has got a bit messy over the years and so it’s probably time to do away with the google wifi pucks and just upgrade everything to TP-Link extenders and a new TP-Link router then they’ll all form their own mesh and hopefully there will be harmony in the household!

If possible get rid of extenders and run cables from your router (or a switch that has a connection to your router) to inexpensive wireless access points that you would place in strategic areas of your home, and then give them all the same SSID (different channels of course). All of your connectivity issues will go away and no more extenders ever needed. And with each device as you walk around in your home you only need to connect once, to one WiFi SSID - and your devices will always automatically connect to the nearest WAP.

I know the below discussion goes a little off track to your exact issue but I believe it can be considered a best practice -

Each hop through an extender can cut the speed in half (and definately reduces the reliability of the connection).

I have a wooden house too with clapboard siding and it was a pain - and even in a few places I have drilled through a wall to the outside and tacked the cable along the outide wall of the house in inconspicuous places to reach other rooms. My WiFi connection is very strong no matter where I go in (our outside, around) my home. This is a shot near a third floor window - I had to really zoom in to even be able to see the Cat6 cable:

Therefore I have what some call a “mesh network with a wired backhaul” - meaning you get full coverage with ZERO loss in speed, there are ZERO WiFi “hops”.

Good luck and tell us how you make out.

Imo you’d be better off just replacing with a proper mesh system rather than use extenders, the Google stuff (or bose or any other mini mesh eco system) will still have their own links.

Like KruseLuds, I have a mesh router/satalie setup with the satalites wired/backhauled to the router and additional switches as needed per room.

Sounds like your on the right track for a solution though!

1 Like