External Access not working (port blocked) with IPv6

Hi guys,

probably another “not working” post, but I haven’t found anything working for me yet…

First my setup:

  • Hassbian running on RPi3
  • Router is a Fritz!Box with DSLite (so no IPv4, only IPv6)
  • DynDNS setup with MyFritz

When setting up port forwarding, I cannot access Home Assistant (or any other port) on the RPi. However, when running Home Assistant on a Docker container on my Synology NAS and open the port to the NAS, I can access it. So it has something to do with hassbian, not the setup around it.
DNS doesn’t seem to be the problem, I can make an nslookup to “homeassistant..net”. But Port scanner (like ipv6scanner.com) reporting the port blocked.

I’ve already re-installed hassbian, so the config is clean.

Is there a firewall or anything setup on hasbian? Anything I can track, where the communication is blocked?

Thanks in advance :slight_smile:

Issue the command: sudo ifconfig and see if the Pi is getting an IPv6 address.

If not you’ll need to enable that via (assuming the kernel hasn’t been modified):

sudo sysctl -w net.ipv6.conf.all.disable_ipv6=0
sudo sysctl -w net.ipv6.conf.default.disable_ipv6=0

Then reboot or sudo sysctl -p

Thanks for your answer :slight_smile: IPv6 is already enabled and this is also the IP the router is forwarding to (or the nslookup shows)

I’ve forgot to mention, HA has been configured to run on IPv6 as well using this line:
server_host: “::0”

No iptables loaded?

Nope, not that I know (its a clean install)

netstat shows hass listening on IPv6 too?

as far as I can tell, yes:
tcp6 0 0 [::]:8123 [::]:* LISTEN

I’ve found something odd… The raspberry has two IPv6 addresses, which should be normal I think (internal and external)… But the fritzbox is only giving me one… How do I know it’s the correct one?

The internal one is something like fe80:::::

Ok, thats the one, the fritzbox pre-selects

My IPv6 starts like 2602::::: but I haven’t attempted to use that for access yet.
fe80::::: is the loopback ie:

OMG, freaking fritzbox… I was replacing the internal IPv6 with the external in the port forwarding screen, which didn’t work… So I deleted the port forward and created it again for the RPi and this time it was pre-selected with the correct (external) IP… What should I say, it seems to work (however could only test it on my PC right now, not externally… But the portscanner says port is open :+1:

So, yeah, I’ve just tested it using my mobile and a port mapper (for IPv4) and its working

I knew it was something so easy and soon resolved, when I open a topic :see_no_evil:

Thanks @firstof9