Fail installing hassio in Odroid XU4


#1

Hello,

I’m trying to install hassio on dietpi OS into an Odroid XU4.
Installed the pre-requisites.
When it reached the part to do this code

curl -sL "https://raw.githubusercontent.com/home-assistant/hassio-build/master/install/hassio_install" | bash -s

instead I did

wget https://raw.githubusercontent.com/home-assistant/hassio-build/master/install/hassio_install
sudo ./hassio_install -m odroid-xu

Everything went great, until I viewed the logs. It looks like the container is trying to pull a docker image with a tag named landingpage, which doesn’t exist.

19-01-10 00:27:55 INFO (SyncWorker_3) [hassio.docker.interface] Pull image homeassistant/armhf-homeassistant tag landingpage.
19-01-10 00:27:57 ERROR (SyncWorker_3) [hassio.docker.interface] Can't install homeassistant/armhf-homeassistant:landingpage -> 404 Client Error: Not Found ("manifest for homeassistant/armhf-homeassistant:landingpage not found").
19-01-10 00:27:57 WARNING (MainThread) [hassio.homeassistant] Fails install landingpage, retry after 60sec

If I could change that to latest, I think I could solve the problem.


#2

I ended up using the script https://github.com/dale3h/hassio-installer
Everything worked perfectly.


#3

Did you use the script just as is or did you do any changes, because looking at this script it just calls the original installer with -m raspberrypi3


#4

I ran the script as it is. Since the raspberry shares the same or almost the same architecture of odroid xu4, worked great