Failed to call service camera/record. camera.raspberry_pi_camera does not support record service

Tags: #<Tag:0x00007f326bc686b8> #<Tag:0x00007f326bc68578>

Hi All,

I created an automation, that supposed to record a video triggered by a PIR motion sensor connected to RPi4. It didn’t work. I tried to test it with camera.snapshot and it works fine, but I really would like to record a video, because one snapshot is not enough.

I started digging deeper and tried to run the service from the developer tools. At least here I get an error message that you see in the $SUBJECT. Here is the set of parameters that I used:

entity_id: camera.raspberry_pi_camera
filename: '/home/homeassistant/videos/inside_{{ now().strftime("%Y%m%d-%H%M%S") }}.mp4'
duration: 10
lookback: 4

I think that it is also worth mentioning that I added the directory /home/homeassistant/videos/ to the list of allowed directories in configuration.yaml

homeassistant:
  whitelist_external_dirs:
    - '/home/homeassistant/videos'

Is there a genuine problem with Raspberry Pi 4 camera, and it truly doesn’t support the record service, or is this a bug? I don’t see why it should be able to capture individual frames but not record a video.