Failed to call service light/turn on: service not found

All was working well until last evening when I was unable to turn off a lamp using the Home Assistant app. When I tap on one of the lights to check the detail it says ‘master BR Lamp Unavailable’. When I tried to initiate it, I get the error message ‘Failed to call service light/turn on: service not found.’ When I checked the automation area the service selection does not contain ANY light/turn on or off functions.

How do I restore the 'light.turn_on’ and ‘’ services? Thanks

Is light: in your configuration.yaml file?

Yes and had been working right for almost a month. I changed to HA when Insteon failed and now regretting it for all the $$$ I’ve invested. Would like to get this back up and running right.

alias: Family Rm On (Sunset)
description: ‘’

  • platform: sun
    event: sunset
    offset: ‘-00:30’
    condition: []
  • service: light.turn_on
    data: {}
    - light.lamplinc_dimmer_27_20_8d
    mode: single

What errors do you see related to lights in the log?

My Insteon Hub is still working (now that Insteon came back online :frowning: ) and I don’t know if that’s what’s causing the issues. On the device page, Insteon, I get an error for ‘retrying setup’ and when I click on ‘check the logs’ I get:
Could not connect to Insteon modem
8:50:54 AM – (ERROR) Insteon - message first occurred at July 24, 2022 at 9:35:32 AM and shows up 2037 times
An client error occurred: Cannot connect to host ssl:default [Connect call failed (‘’, 25105)]
8:50:54 AM – (ERROR) /usr/local/lib/python3.10/site-packages/pyinsteon/protocol/ - message first occurred at July 24, 2022 at 9:35:32 AM and shows up 2037 times
Config entry ‘’ for insteon integration not ready yet; Retrying in background
July 24, 2022 at 9:35:32 AM – (WARNING)

When I go to the Settings > Automation, the YAML still runs BUT when I go to the Overview Dashboard nothing works. If a light has been turned on the dashboard will be grey out.

Just very frustrated.

So the problem is that you are not connected to your Insteon hub. I know nothing about Insteon unfortunately.

Hi. A couple of debugging questions:

  1. Have you restarted HA and your hub to see if the issue is fixed with a restart? A restart generally fixes hub connection issues.
  2. Is it possible the hub has changed IP addresses? If HA does not know the correct IP address this same error can occur.

I also see this on one of my blueprints … on one of my test systems.
I call this with an entity_id: []
The cause was because I had NO light entities created in that instance … so the service was not there.

And I fixed the error by adding the following to configuration.yaml