Failed to call service update/install

Unable to do anymore update due to Home Assistant Supervisor Update failed- Any advice? Getting error -

Failed to call service update/install. Error updating Home Assistant Supervisor. Update of Supervisor failed: Can’t install 404 Client Error for
supervisor.2023.10.0/json: Not Found (“No such image: supervisor.2023.10.0”)

did you ever get to the bottom of it? I have exactly the same error

1 Like

Same problem here. Have not found a solution for weeks now. So annoying. Has anyone had any luck?

I ran into this issue myself. Check the DNS address your HA machine is using. I had this error when trying to update and eventually realized my HA was pointed to a DNS server I had taken down months ago but forgot to update on HA. When I pointed it to a working DNS and tried again the update worked with no error.

Just to add my bit to this, ages after the event. I had the same problem, same error message and it was because I had “backup” checked on the update screen and my backups are set to go to a network drive. In the “repair” section of settings it was saying my network drive was disconnected. Pressing reload there fixed that and the updates then installed.

Reiterating what GeNomer stated. I installed a new router and disconnected my PiHole temporarily (some day I’ll get around to putting it back in…) and was having the same error trying to install the updates due to the DNS issue.

You’ll want to go to Settings > System > Network, and then under the “Configure network interfaces” and expand the “IPv4” entry. If you had it static, update your DNS address to or whichever your preference is. You might be able to try setting to automatic as well.

Note: I tried restarting a couple times and it still didn’t work. Make sure you “REBOOT” instead of restart and that solved my issue.

This is it. I updated the DNS entry and i worked after a REBOOT. I would like to know what domain my piHole was blocking though since I don’t see any blocked queries from that IP address.