Failed to compile image

An error occurred when I ran the operating-system in the official way

  • I ran this command—> sudo scripts/ make rpi3_64
123@123-ha:~/work/operating-system$ sudo scripts/ make rpi3_64
[+] Building 0.9s (10/10) FINISHED
 => [internal] load build definition from Dockerfile                                                                                  0.0s
 => => transferring dockerfile: 1.35kB                                                                                                0.0s
 => [internal] load .dockerignore                                                                                                     0.0s
 => => transferring context: 99B                                                                                                      0.0s
 => [internal] load metadata for                                                                    0.7s
 => [1/5] FROM              0.0s
 => [internal] load build context                                                                                                     0.0s
 => => transferring context: 65B                                                                                                      0.0s
 => CACHED [2/5] RUN apt-get update && apt-get install -y --no-install-recommends         apt-transport-https         ca-certificate  0.0s
 => CACHED [3/5] RUN apt-get update && apt-get install -y --no-install-recommends         bash         bc         binutils         b  0.0s
 => CACHED [4/5] COPY scripts/ /usr/sbin/                                                                                     0.0s
 => CACHED [5/5] WORKDIR /build                                                                                                       0.0s
 => exporting to image                                                                                                                0.0s
 => => exporting layers                                                                                                               0.0s
 => => writing image sha256:1b1d84ccb37c5e5579fd08a0a8fa1b756b26bccf78d873c0c7efde2752280c12                                          0.0s
 => => naming to                                                                                       0.0s
WARNING: buildx: failed to read current commit information with git rev-parse --is-inside-work-tree
config rpi3_64
/usr/bin/make -C /build/buildroot O=/build/output BR2_EXTERNAL=/build/buildroot-external "rpi3_64_defconfig"
make[1]: Entering directory '/build/buildroot'
  GEN     /build/output/Makefile
# configuration written to /build/output/.config
make[1]: Leaving directory '/build/buildroot'
build rpi3_64
/usr/bin/make -C /build/buildroot O=/build/output BR2_EXTERNAL=/build/buildroot-external VERSION_DEV="dev20230713"
make[1]: Entering directory '/build/buildroot'
/usr/bin/make -j1 O=/build/output HOSTCC="/usr/bin/gcc" HOSTCXX="/usr/bin/g++" syncconfig
make[2]: Entering directory '/build/buildroot'
  GEN     /build/output/Makefile
make[2]: Leaving directory '/build/buildroot'
>>> hassio 1.0.0 Installing to images directory
/build/buildroot-external/package/hassio/ "/build/output/build/hassio-1.0.0" "/build/output/images"
mke2fs 1.46.2 (28-Feb-2021)
Discarding device blocks: done
Creating filesystem with 327680 4k blocks and 81920 inodes
Filesystem UUID: 18d74762-b4be-4ca9-87f7-7345d86611b3
Superblock backups stored on blocks:
        32768, 98304, 163840, 229376, 294912

Allocating group tables: done
Writing inode tables: done
Creating journal (8192 blocks): done
Writing superblocks and filesystem accounting information: done

Unable to find image 'docker:20.10-dind' locally
20.10-dind: Pulling from library/docker
8a49fdb3b6a5: Pull complete
db1d8fde5ab0: Pull complete
f3759a44eb9f: Pull complete
1465fd8ca4ab: Pull complete
95c1bc752a8b: Pull complete
f5ce33fb9a21: Pull complete
4d37eec86745: Pull complete
49d0e23604c0: Pull complete
ac56a29f30eb: Pull complete
0184c8e99504: Pull complete
23430c064101: Pull complete
e2a9b00eaf87: Pull complete
004faac3bc86: Pull complete
765a9f2e0717: Pull complete
Digest: sha256:af96c680a7e1f853ebdd50c1e0577e5df4089b033102546dd6417419564df3b5
Status: Downloaded newer image for docker:20.10-dind
Waiting for Docker daemon...
Loading container images...
Loaded image:
open /var/lib/docker/tmp/docker-import-643693548/repositories: no such file or directory
make[1]: *** [package/ /build/output/build/hassio-1.0.0/.stamp_images_installed] Error 1
make[1]: Leaving directory '/build/buildroot'
make: *** [Makefile:39: rpi3_64] Error 2

What I use is

167~18.04.1-Ubuntu SMP Wed May 24 00:51:42 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux

docker version

Docker version 24.0.2, build cb74dfc
  • Somebody help me

You’ve tagged this post as Home Assistant OS, but you then talk about Docker containers. Can you point us to the documentation for the install method you are using?


Getting Started with Home Assistant Operating System Development | Home Assistant Developer Docs (

Ah - so you may be better asking on Discord where all the devs hang out. 99% of users on the forum don’t do HA development.

Ok, thank you for your reply