Failed to connect to ESP32: No serial data received

I have several ESP32 devices working nicely with ESPHome and Home Assistant but ones of the esp32’s that used to work before suddenly stopped working. I’ve read the troubleshooting info in Github and other articles then I found solution like this.ESP32 install - no serial data received
but I can’t solved my problem.

I am using the ESPHome interface in Home Assistant.
I succeed compiling part, but I failed to connecting part.

INFO Reading configuration /config/esphome/esp3.yaml...
INFO Generating C++ source...
INFO Compiling app...
Processing esp3 (board: esp32dev; framework: arduino; platform: platformio/espressif32 @ 3.5.0)
Library Manager: Installing Hash
INFO Installing Hash
Library Manager: Installing ESP8266WiFi
INFO Installing ESP8266WiFi
HARDWARE: ESP32 240MHz, 320KB RAM, 4MB Flash
LDF: Library Dependency Finder ->
Dependency Graph
|-- AsyncTCP-esphome @ 1.2.2
|-- WiFi @ 1.0
|-- FS @ 1.0
|-- Update @ 1.0
|-- ESPAsyncWebServer-esphome @ 2.1.0
|   |-- AsyncTCP-esphome @ 1.2.2
|-- DNSServer @ 1.1.0
|-- ESPmDNS @ 1.0
|-- noise-c @ 0.1.4
|   |-- libsodium @ 1.10018.1
RAM:   [=         ]  12.6% (used 41228 bytes from 327680 bytes)
Flash: [=====     ]  52.7% (used 966174 bytes from 1835008 bytes)
========================= [SUCCESS] Took 11.18 seconds =========================
INFO Successfully compiled program. v3.3.1
Serial port /dev/ttyUSB0

A fatal error occurred: Failed to connect to ESP32: No serial data received.
For troubleshooting steps visit:
INFO Upload with baud rate 460800 failed. Trying again with baud rate 115200. v3.3.1
Serial port /dev/ttyUSB0

A fatal error occurred: Failed to connect to ESP32: No serial data received.
For troubleshooting steps visit:

I’m using HA OS 8.5 on a Raspberry Pi 4 Model B. The ESP module is plugged into one of the USB ports on the Pi, which I selected during the guided installation process. The board is still bare, with nothing connected to any of the pins.
Another ESP32 devices working.

Please can you help shed some light on this and perhaps suggest how I might resolve this?

Could be a broken device?

Thank you for reply!

I don’t think it’s broken, because light being illuminated all the time.
I’m attaching a picture.

Just because the light is on, it doesn’t mean the device is fully functional.

Are you sure it is on /dev/ttyUSB0? Check with dmesg.

I don’t know how to check with dmesg, so I checked from ESPhome in home assistant .
I’m attaching a picture.
Is it ok or not?

Looks like it.

Does that mean it’s not broken?

No it doesn’t mean that.


I want to solve this problem, so what should I do?

Try with esptool.

I think you have to hold down the BOOT button and then press the EN button. After that, it’s in flash mode

I will try it.
Thank you!

I already tried it but ,it didn’t change.

You could also try to keep the boot button pressed while putting the cable in the board

Thank you for advise.
I already tried it but ,it didn’t change.

Hi, I had a similar issue. I resolved it by doing the following:

I had normal serial communication to my ESP ie I could see the usual boot messages and the boot logs in my serial monitor. However I could not upload a new sketch or program.

Pull IO 0 to Ground (the prog or boot button should do this).
While IO 0 is pulled to ground Pull EN or the enable pin low. this will place the ESP into the programming mode.

I assume you either don’t have the proper driver or try to connect your ESP32 to the wrong COM port.
I’ve fixed the same issue with the updating of the USD-to-UART driver. you can download it here:
CP210x USB to UART Bridge VCP Drivers - Silicon Labs (
Good luck

I guess you are holding both buttons, Perhaps you need to connect the board with a USB cable and check the device manager to ensure your COM port is activated for the board. HOLD out (Boot) button, Only PRESS EN (reset) button once while still holding the Boot button. Definitely, pressing "Upload and Monitor, or Upload File System Image will load the FW into the board.