"Failed to connect" when trying to integrate Shelly 2.5 configured as shutter

Hi all,

I am trying to integrate a Shelly 2.5 with latest stock firmware into my Home Assistant installation. The Shelly is configured to use the Home Assistant host’s IP and port 5683 as per the integration documentation:

When I try to add the Shelly integration in Home Assistant I am asked for a host. I enter the Shelly’s IP Adress assuming this is what needs to be entered there and a few seconds later I get a “Failed to connect”

There is nothing in the Home Assistant logs pointing to an error. The Shelly logs see that the Home Assistant host is connecting, but nothing happens:

135715985 mgos_http_server.c:180  0x3fff301c HTTP connection from 172.16.0.4:53252
135748966 mgos_http_server.c:180  0x3fff314c HTTP connection from 172.16.0.4:53254
135779871 mgos_http_server.c:180  0x3fff3204 HTTP connection from 172.16.0.4:53256
135899160 mgos_http_server.c:180  0x3fff3244 HTTP connection from 172.16.0.4:53258

I would be grateful for any pointers how to debug this further or fix it.

I am running Home Assistant OS 2012.12.9:

System Health

version: core-2021.12.9
installation_type: Home Assistant OS
dev: false
hassio: true
docker: true
user: root
virtualenv: false
python_version: 3.9.7
os_name: Linux
os_version: 5.10.63-v8
arch: aarch64
timezone: Europe/Berlin

logged_in: false
can_reach_cert_server: ok
can_reach_cloud_auth: ok
can_reach_cloud: ok

host_os: Home Assistant OS 7.1
update_channel: stable
supervisor_version: supervisor-2021.12.2
docker_version: 20.10.9
disk_total: 28.7 GB
disk_used: 3.6 GB
healthy: true
supported: true
board: rpi4-64
supervisor_api: ok
version_api: ok
installed_addons: Studio Code Server (4.1.0), Node-RED (10.3.3)

dashboards: 1
resources: 0
views: 1
mode: storage

api_endpoint_reachable: ok

My Shelly is configured fine, shutter is calibrated and working as expected when using the Shelly’s built-in web interface. It is running latest stock firmware 20211109-125214/v1.11.7-g682a0db.

Never mind. After poking into Home Assistant’s debug logs and finding nothing I factory reset the Shellies as a last resort and everything started working out of the box. No clue what caused this.

This is STILL happening as of September 2022. I just had a power cut, and my shelly EM and shelly plus1 PM got stuck offline.

image

I tried to remove them and re-add them, but they’d Failed to connect. I restarted the shellys, no luck.

image

The WebUI for both Shelly devices still worked perfectly. I ran out of time to fix it so I ended up factory resetting both - at which point I was able to add them back into HASS via the integration without any issues.

I also have 1 x Shelly 2.5 here. That one worked perfectly once the power came back on.

I have the same issue with two Shelly TRV devices (firmware 20220811-152343/[email protected]).
With both devices, I’m able to connect to the Shelly WebUI, but HASS is not able add them, die to failed login.
I tried also a reset and reconfiguration of the Shelly’s without success.
Both devices are new and I don’t added them before.

Had the same issues after a powerout, turns out that re(?)-enabling CoIoT solved the connection issues. It was especially frustarting since DEBUG logs from HA showed HA receiving all the available data from my Shelly 2.5 prior to telling me “Failed to connect”

image