Failed To Install on Yellow, stuck at [ 35.804738] cam-dummy-reg: disabling

Hey folks, im having a lot of problems with the Home Assistant,

I had it all working- The original install worked just as the docs from USB.
Hardware Here:
Home Assistant Yellow Kit
1 x Home Assistant Yellow Kit with Power Supply

Raspberry Pi Compute Module
1 x Raspberry Pi Compute Module 4 - 4GB RAM, 16GB eMMC, 2.4/5.0GHz Wi-Fi & Bluetooth 5.0 (CM4104016)

I restored a back up, and the entire system crashed. No problem i thought, i have lost a lot of work but i have learnt a lot of lessons! (and i managed to have a backup of all my SmartIR AC settings, that was the worst part!) - If it matters, i was restoring a back up because my SSH port was failing to open in the log of the SSH terminal addon. I was hoping to fix this by rolling back to my first back up.

I tried first to use the Red button for 10 seconds method here, FAQ – Home Assistant Yellow

No luck- So then i tried to reflash the system from this page How to reinstall the operating system – Home Assistant Yellow
First i tried Option one- no matter how long i held the buttons the yellow light would start flashing.

So i decided to connect up the serial cable, i got this msg

[    9.976142] random: 7 urandom warning(s) missed due to ratelimiting
[  OK  ] Started Network Name Resolution.
[  OK  ] Reached target Network.
[  OK  ] Reached target Host and Network Name Lookups.

Welcome to Buildroot
yellow-installer login: [   17.628935] vc4-drm gpu: [drm] Cannot find any crtc or sizes
[   35.804738] cam-dummy-reg: disabling

OK, its a bit beyond me- so i would try Option 2.
Everything worked without any strange messages. When i plug in the power and ethernet again i just get the Yellow heart beat. 2 pulses then a pause, just like before i tried option 1, and after.

The Serial message stops at the same log as above.

I can login to buildroot by typing root and hitting enter. This allows me to do a few commands, but im out of my depth here.

I don’t have a SSD installed, but can buy one if it will help.
Here is the full log, if its useful to anyone!

Im not sure what my next steps are here, looking for advice from the community!
Thank you so much for your time!

Some extra infomation, when it is stuck on that final log, if i press the red button i get this additional log

Welcome to Buildroot
yellow-installer login: [   17.628949] vc4-drm gpu: [drm] Cannot find any crtc o r sizes
[   35.804710] cam-dummy-reg: disabling
[   38.548205] input-event-daemon[243]: key_event:
[   38.548856] input-event-daemon[243]:   code     : BTN_1
[   38.549175] input-event-daemon[243]:   source   : /dev/input/by-path/platform-gpio-keys-event
[   38.549468] input-event-daemon[243]:   exec     : "/usr/bin/haos-flash dev auto"
[   38.580469] input-event-daemon[246]: Getting latest Home Assistant OS versionfrom channel dev...
[   38.602259] input-event-daemon[249]: curl: (6) Could not resolve host:

And if i hit the blue button i get the followingl

[   88.700504] input-event-daemon[243]: key_event:
[   88.701237] input-event-daemon[243]:   code     : POWER
[   88.701566] input-event-daemon[243]:   source   : /dev/input/by-path/platform-gpio-keys-event
[   88.701843] input-event-daemon[243]:   exec     : "/usr/bin/haos-flash stable nvme"
[   88.729347] input-event-daemon[252]: Getting latest Home Assistant OS version from channel stable...
[   88.729906] input-event-daemon[252]: Force installation on NVMe drive...
[   88.749873] input-event-daemon[255]: curl: (6) Could not resolve host:

I’m not sure if this is useful or not- at least it proves the input is somewhat functional.

I have also tried to reinstall the firmware of the CM4, from these docs here, as i saw some errors in that log related to the CM4.

No luck, same outcome

Did you ever figure out what was going on with your system? I was able to get “option 2” to work to load a new image. However, it is not outrunning the installation now. When I connect to the serial port, the login prompt is “yellow-installer login”