Failed to switch to cgroup v1 error on manual supervisor install

I have tried installing this multiple times but still getting the same error of:

Could not find /etc/default/grub or /boot/firmware/cmdline.txt failed to switch to cgroup v1

I worked through the manual install for superviser including installing docker, etc and everything completes but upon installing I still get this error thrown part way through the install.

I am running RaspberryPI 4 OS 64bit OS and trying to install this manually onto it…



Unfortunately, I don’t have a fix for this but wanted to mention that I am having the same issue. However, I had the issue whilst on Raspberry PI OS 32-bit also. I had a number of repairs showing and so decided to wipe my SD card and start again with 64-bit. I see the same warning with cgroup when installing homeassistant-supervised.

Do you still have this problem or do you have a fix?

I also have an AppArmour issue.

I have fixed this issue by adding: systemd.unified_cgroup_hierarchy=0 to /boot/cmdline.txt.

I fixed my AppArmor issue by adding: apparmor=1 security=apparmor to the same file.

Hope this helps.


Is it not in /proc/cmdline ?

What looks like solved all 3 repairs was just updating the supervisor as per these commands:

I didn’t realize the supervisor needed to be updated until I saw this in the terminal:

Unpacking homeassistant-supervised (1.4.1) over (1.1.0) …

I’m hoping and assuming it also fixed the app-armor failed error on start up (even though the service was running anyway)