Failing Homematic(IP) Integration config

Hi. I successfully installed RaspberryMatic and now I’m trying to install Homematic(IP) Local integration, but I’m getting the error “Failed to Connect” when I submit the configuration data.
The log only gives a unusefull message with no description:

Logger: hahomematic.central

Source: custom_components/homematicip_local/
Integration: Homematic(IP) Local ([documentation](, [issues](
First occurred: 13:56:16 (2 occurrences)
Last logged: 13:57:17

I already have setted the firewall configuration in Raspberrymatic to the less secure possible (“Ports Open” and Full Access) and even with this configuration I have tried to add ports mentioned here to the Opening ports list and I have tried to add Ips from my LAN to the “IP addresses for restricted access” and even the IP I think HA is using internally to comunicate with RaspberryMatic (as ifconfig shows)

I even have tried to change the hostname of RaspberryMatic with the IP that nslookup gives me (

But nothing works, always the same error and the same log error.
I only have obtained different log error when I change the hostname to the one that Raspberrymatic shows in its GUI, in that case I obtain a “destination host unreachable” as expected. And I obtained a different error too when I uncheck all the checkboxes in “Configure the interfaces to CCU”, in that case, the connection fails again but no error is logged at all.

I have no RF interfaces connected yet (neither USB nor GPIO one, I’m waiting them) so I’m wondering if the connection is failing just because I don’t already have the hardware interfaces connected…

Any ideas?

That’s exactly the reason. RaspberryMatic doesn’t startup the relevant services if the matching hardware is missing. Hence the integration has nothing to connect to.

So the only think I can do by now is to wait the shipment and then try again…
Thank you for the info.