Failing to add HomeKit Matter device to HA

I have a Wemo Matter smart plug - it is connected to HomeAssistant and is nice and responsive in the Apple Home app. This is my second attempt to set it up as a Matter device.

The first attempt went like this:
Wemo smart plug (Matter) added to Wemo App and Apple Home.
Tested and is responsive.

Then to add it as a matter device in HA, I removed from Apple home.
Held power button whilst plugging it in and it was proposed as a new device in the Wemo app.
Tried the HA Matter integration but never saw the plug.
Continued in the Wemo app - which failed.
Spent two hours trying different combinations of WiFi, Bluetooth, button press combinations to finally get the blinking orange/white pairing option and Apple Home added it.
But the Wemo app does not know about it.

Now it is again known to Apple Home I tried the HomeKit Device integration and Add Devices shows the Wemo Plug 247 (Outlet).

The next step always ends in error - normally it is something unhelpful like unknown error, but this time I got some detail:

An unhandled error occurred while attempting to pair with this device. 
This may be a temporary failure or your device may not be supported currently: Wemo Plug 247
(CB:92:3A:C3:FF:A7) - CB:92:3A:C3:FF:A7: Failed to connect after 9 attempt(s): 
No backend with an available connection slot that can reach address CB:92:3A:C3:FF:A7 was found:
The proxy/adapter is out of connection slots or the device is no longer reachable; 
Add additional proxies ( near this device

What does this message mean?

1 Like

It means the system wasn’t able to reach the plug by Bluetooth for commissioning…

Hows your Bluetooth coverage (by ha not your mobile device) where the plug is?

I have a HA Yellow and the RPi 4 module has bluetooth.
HA shows a bluetooth integration is active, but I’ve never seen any logs etc.
How can I test bluetooth coverage of the HA Yellow?


Test - difficult. Make an educated guess? my Bluetooth devices have a max range of about 30’ - If its farther than that or if there’s a lot of ‘stuff’ (walls, people, furniture, a battleship) between them the range is much shorter. I can successfully connect to Bluetooth stuff in the same room - MAAAAYBE the next room over but not more than that. But if I understand the docs correctly, at the end of the day the key is distance between the end device and HA’s bluetooth connection - not your phone’s bluetooth connection.

Should my iPhone be able to see HA bluetooth / what would it be called?

Got back to this today.
Relocated the Wemo 247 Matter smart plug to a socket next to HA Yellow (and Apple TV).

  • Removed the device from Apple Home
  • Spent twenty or so minutes trying to the the switch in pairing mode - finally got there - something like hold pwr button when plugging in for 15 seconds the several rapid presses. Orange / White flashing
  • Used the HA iOS app > devices > add
  • Very slow, not much going on. Eventually get a prompt asking to scan the code - the sticker is a WiFi symbol so cannot be scanned.
  • Used the manual option and entered the code in XXXX-XXXX format.
  • Device endlessly sits and connecting (this make take some time).
  • Meanwhile on MacBook Safari integrations page - TWO WEMO 247 smart plugs are showing up (possibly as HomeKit devices).
  • Clicked on one - used the pairing code - this time it had to be in XXX-XX-XXX format.
  • After five minutes, the two new devices disappear, and one appears as a HomeKit integration.

I’ve not tried to export this plug to HomeKit.

Looks like the setup was done under Apple HomeKit and not Matter.

The Bluetooth integration did have logging enabled and I did capture this

2023-11-09 10:25:29.481 DEBUG (MainThread) [bleak_retry_connector] Wemo Plug 247 (C4:54:84:0F:C2:D0) - C4:54:84:0F:C2:D0: Connection attempt: 1
2023-11-09 10:25:29.482 DEBUG (MainThread) [homeassistant.components.bluetooth.wrappers] C4:54:84:0F:C2:D0 - Wemo Plug 247 -> /org/bluez/hci0: Connecting (last rssi: -65)
2023-11-09 10:25:29.947 DEBUG (MainThread) [homeassistant.components.bluetooth.wrappers] C4:54:84:0F:C2:D0 - Wemo Plug 247 -> /org/bluez/hci0: Connected (last rssi: -65)
2023-11-09 10:25:29.947 DEBUG (MainThread) [bleak_retry_connector] Wemo Plug 247 (C4:54:84:0F:C2:D0) - C4:54:84:0F:C2:D0: Connected after 1 attempts
2023-11-09 10:25:37.094 DEBUG (MainThread) [homeassistant.components.bluetooth.base_scanner] hci0 (E4:5F:01:65:DC:2D): Scanner watchdog time_since_last_detection: 5.999938755994663
2023-11-09 10:25:39.214 DEBUG (MainThread) [bleak_retry_connector] Wemo Plug 247 [C4:54:84:0F:C2:D0] (id=03:2F:85:CA:FD:7C) - C4:54:84:0F:C2:D0: Connection attempt: 1
2023-11-09 10:25:39.215 DEBUG (MainThread) [homeassistant.components.bluetooth.wrappers] C4:54:84:0F:C2:D0 - Wemo Plug 247 -> /org/bluez/hci0: Connecting (last rssi: -65)
2023-11-09 10:25:44.685 DEBUG (MainThread) [homeassistant.components.bluetooth.manager] hci0 (E4:5F:01:65:DC:2D) [connectable]: C4:54:84:0F:C2:D0 AdvertisementData(local_name='Wemo Plug 247', manufacturer_data={76: b'\x061\x00\x03/\x85\xca\xfd|\x07\x00\x01\x00\x01\x02m\xaf\x02\x03'}, service_uuids=['0000003e-0000-1000-8000-0026bb765291', '00000047-0000-1000-8000-0026bb765291', '00000055-0000-1000-8000-0026bb765291', '000000a2-0000-1000-8000-0026bb765291', '00000129-0000-1000-8000-0026bb765291', '00000236-0000-1000-8000-0026bb765291', '00000239-0000-1000-8000-0026bb765291', '00000701-0000-1000-8000-0026bb765291', '00001800-0000-1000-8000-00805f9b34fb'], rssi=-66) match: set()
2023-11-09 10:25:45.131 DEBUG (MainThread) [homeassistant.components.bluetooth.wrappers] C4:54:84:0F:C2:D0 - Wemo Plug 247 -> /org/bluez/hci0: Connected (last rssi: -65)
2023-11-09 10:25:45.132 DEBUG (MainThread) [bleak_retry_connector] Wemo Plug 247 [C4:54:84:0F:C2:D0] (id=03:2F:85:CA:FD:7C) - C4:54:84:0F:C2:D0: Connected after 1 attempts
2023-11-09 10:26:07.102 DEBUG (MainThread) [homeassistant.components.bluetooth.base_scanner] hci0 (E4:5F:01:65:DC:2D): Scanner watchdog time_since_last_detection: 20.771786571014673
2023-11-09 10:26:37.103 DEBUG (MainThread) [homeassistant.components.bluetooth.base_scanner] hci0 (E4:5F:01:65:DC:2D): Scanner watchdog time_since_last_detection: 50.7714761539828
2023-11-09 10:26:43.292 DEBUG (MainThread) [homeassistant.components.bluetooth.manager] hci0 (E4:5F:01:65:DC:2D) [connectable]: 82:E8:2C:5E:03:20 AdvertisementData(service_data={'0000fdf7-0000-1000-8000-00805f9b34fb': b'\x01\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x03'}, service_uuids=['0000fdf7-0000-1000-8000-00805f9b34fb'], rssi=-70) match: set()
2023-11-09 10:26:43.479 DEBUG (MainThread) [homeassistant.components.bluetooth.manager] hci0 (E4:5F:01:65:DC:2D) [connectable]: 82:E8:2C:5E:03:20 AdvertisementData(manufacturer_data={101: b'\x01\xc9\x02'}, service_data={'0000fdf7-0000-1000-8000-00805f9b34fb': b'\x01\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x03'}, service_uuids=['0000fdf7-0000-1000-8000-00805f9b34fb', '0000fe78-0000-1000-8000-00805f9b34fb'], rssi=-76) match: set()
2023-11-09 10:26:43.632 DEBUG (MainThread) [homeassistant.components.bluetooth.manager] hci0 (E4:5F:01:65:DC:2D) [connectable]: 47:15:6A:9C:08:E5 AdvertisementData(manufacturer_data={76: b'\x10\x06{\x1d\xb2V\xd6\x08'}, tx_power=12, rssi=-69) match: set()
2023-11-09 10:26:43.742 DEBUG (MainThread) [homeassistant.components.bluetooth.manager] hci0 (E4:5F:01:65:DC:2D) [connectable]: 4B:22:E3:C1:D3:35 AdvertisementData(manufacturer_data={76: b'\x10\x07\x19\x1f($\xcf\x0e\x18'}, tx_power=7, rssi=-85) match: set()

The smart plug is working, it shows as a HomeKit device and is very slow to respond - 30 seconds for first connection and then fast as long as I keep it busy.