Fan Domain and Alexa through Nabu Casa

Since I have upgraded to 2021.10.x my fan domain will no longer sync with Alexa. I use Nabu Casa to sync.
My ceiling fans are iFan03 with Tasmota.
I’ve tried turning off all other domains except fans, restarting Home Assistant, removing and re-adding the skill on alexa app, reloading the Tasmota integration and restarting all iFan03.
I don’t know what else to try to get the fans back into my Alexa App.

Thanks ahead for any help

I appear to be having the same issue on the manual setup (without Nabu Casa) Alexa integration. I had a few fans where speed control wasn’t working so I removed them thinking that maybe HA changed something with fan speeds again and I needed to resync them, but no luck, they don’t get detected now. I tried removing a fan without speed support (it’s actually a template fan controlling a switch,) and that one would detect again after the removal. I had just redone my Alexa setup last month on 2021.9.x (because of fan speed changes breaking things…) and know I had these fans detecting and working on that release.

I found this issue: Sounds familiar. I’m not sure this is limited to Z-wave, speed control wasn’t working for both Z-wave and Bond fans for me and neither came back after removing when running discovery.