Fans using GE 14827 switch and Zwave JS aren't working

I’m fairly new to Home Assistant, but getting the hang of things and have a few automations written in Node-Red already as well. My goal is to replace Smartthings with HA because of the flexibility.

My HA instance is running on a Linux VM on my Unraid server. I recently installed a zwave stick ( HUSBZB-1) and added all of my light switches and fan switches. All of my lights are working correctly, I can control them from the overview screen in HA and in Node-Red.

Although I added my fan switches in the same manner as the light switches, none of them will work from either the overview screen in HA or Node-Red. When I manually turn the switch on or off, the status in the overview screen is reflected correctly, I just can’t seem to control them via software.

I searched the forums for my specific fan switch (GE 14827) and found some threads that were quite old and related to Open Zwave. I am using Zwave JS so I wasn’t sure if those were still applicable.

Has anyone experienced anything similar to this? Any help would be greatly appreciated.


It’s fixed in an unreleased version of node-zwave-js. Unfortunately, you’ll either need to wait for an update, somehow downgrade to a version of node-zwave-js prior to 6.3.0, or manually edit the device config file, which may be difficult depending on how you’ve installed zwave-js.

Thanks for the response. Glad to hear it’s just a bug and nothing that I did wrong :). Do updates generally take a while? If it’s days/weeks, it’s no problem, if it’s months, my family may revolt!

If it takes that long, I can try to do the update myself as you mentioned. I added zwave-js as an integration through the HA GUI. Can you give a high level overview of how to edit the device config file?

Thanks again!

Not sure if you’re running into the same thing… but when I moved to the most recent update, it changed my fan switch from a light.(my fan name) to a fan.(my fan name)
I had to go through my automations/etc and update the light vs fan portion and it all came back together. Be sure to change the service type in Node Red for everything to work correctly.
The other change is it made low/med/high available in addition to just % driven.

Sorry, I don’t know how to access or edit the files in the addons.

The fix would depend on the addons being updated to use a new version of node-zwave-js, so it’s hard to answer when that will happen. First node-zwave-js needs to be updated, then the addons.

node-zwave-js updates fairly often, so hopefully it won’t take too long.

Thank you both for the responses.

Mine does say fan.whatever, it just doesn’t work. It seems though as @freshcoast pointed out that there is a bug related to my fan switch.

I’ll do some digging to see if I can figure out how to update that device file. Worst case scenario, I can just keep my smartthings hub plugged in and integrate it with HA to control the fans until the update of ZwaveJS happens.

Not specifically related to this issue but…

Do you know where the config files are located in a docker zwavejs2mqtt install?

If you download a network dump from HA, it will tell you.

"filename": "/usr/src/app/node_modules/@zwave-js/config/config/devices/0x0000/zst10-700.json",

So if you know how to enter the container, you could edit the file to fix the fan problem.

1 Like

Just switched over to Zwave JS and having the same issue with two GE 14287 fan switches. They both show in HA and do report current state but they will not turn on through HA or change fan speed.

Log says:
20:26:02.337 CNTRLR [Node 015] Timed out while waiting for a response from the node

It’s now fixed in node-zwave-js 6.6.1. Upgrade your containers, or if using addons submit issues to those addon projects and request an update.

node-zwave-js 6.6.1 fixed turning on/off fans but I still can’t control fan speed. Is fan speed with GE 14287 switches working for anyone else?

How are you trying to control the speed? There are no speeds settings in HA any more, there’s speed percentages. Is that your issue? (My non-14287 fan controller works fine).

Zwave-js fans also don’t have any presets yet that might be used to set speeds low/med/high.

I was using the “ZWaveJS2MQTT” control panel, HA and HomeKit to set the percentage. Reinterviewing the node and/or changing the speed with the physical switch seems to have resolved the issue.

You should be able to upgrade to 6.6.3. This fixed it for me. There is still a slight issue in HA UI with fan speed showing as percent slider. The slider does work, though, to control the speed (at least for me).
The mobile app shows options for low, medium, and high.

For those of us not using the zwavejs2mqtt, is there any way to reinterview the node?

EDIT: Kind of a pain, but I excluded it and then added it back in. Seems to be working now. Just need to the others.