Ffmpeg config in hass.io

I cannot seem to rotate my video
I have added


to my config yaml (and I am assuming I don’t have to say where the binary is located as I am using hass.io)
and for my camera I have:

  - platform: ffmpeg
    name: Hallway
    input: rtsp://admin:[email protected]

I tried adding

    extra_arguments: rotate=180


extra_arguments: transpose=1

I also tried adding these arguments inside inverted commas such as

extra_arguments: "transpose=1"

but I don’t know whether that is supposed to be important or not! Never quite sure of quoting requirements in yaml.

Any tips on this would be appreciated!

This is what i did and it works for me :slight_smile:

  - platform: ffmpeg
    name: HallCAM
    input: rtsp://IPADRESS:PORT/h264
    extra_arguments:  "-vf 'transpose=1' "
1 Like

Hello I’m trying to see my camera, on my Hassio, if I use VLC i can with this configuration:


I wrote this in my configuration.yaml:



  • platform: ffmpeg
    name: cam1
    input: rtsp://admin:1234!@

But i get online the preview and on the image there is written “inactive”

I know there is the onvif platform but it doesn’t work for me.

in log i get:

2019-05-28 11:48:09 INFO (MainThread) [homeassistant.components.stream] Started stream: rtsp://admin:1234!@
Traceback (most recent call last):
File “/usr/local/lib/python3.7/site-packages/aiohttp/web_protocol.py”, line 275, in data_received
messages, upgraded, tail = self._request_parser.feed_data(data)
File “aiohttp_http_parser.pyx”, line 523, in aiohttp._http_parser.HttpParser.feed_data
aiohttp.http_exceptions.BadStatusLine: invalid HTTP method
2019-05-28 11:48:10 ERROR (stream_worker) [libav.rtsp] Nonmatching transport in server reply

Any idea?