FFMPEG Config on Macos

I’m trying to configure an rstp feed on an HA install on macos. I have successfully connected to the rstp feed using vlc without issue.

When trying to connect to the feed in HA the log outputs:

PermissionError: [Errno 13] Permission denied: '/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/ffmpeg'

The folder exists and I’m running hass under sudo.

I’m new to HA and Python (but not programming), so am aware this could be trivial.

Anybody have any pointers please?

I’ve also now got this running using ffmpeg in the terminal, so this looks like a general python setup/permissions issue.

Any pointers please?

Stuart,
Did you ever get a solution? I too am running Hass on an IMac with pretty good success. I can also see my video feed with VLC, but still no luck with Home Assistant. Anything you’ve learned along the way would be helpful. Thanks.
kartcon (Art)

I gave up on this, and revisited using the generic camera platform. At some point it there was an update so that it worked out of the box with my hikvision cameras.