FFMPEG not showing errors, but no stream in Lovelace

I am running HA on:

  • Raspberry PI 4
  • HA version 0.109.6
  • ffmpeg version 4.1.4-1+rpt7~deb10u1
  • I am running in a virtual Python environment with, hass --open-ui

I have tested my RTSP stream in vlc, and using ffmpeg and both are successful. I have replicated the arguments that HA passes to ffmpeg and it is successful streaming when outside of HA. I have tried about 10 different extra_argument configurations as well, basically whatever I could find through this forum and other googling that people have tried and all get the same result, which is no errors in HA but no picture or stream on my screen.

Configuration in YAML
ffmpeg_bin: /usr/bin/ffmpeg


  • platform: ffmpeg
    name: Front Door Camera
    input: -rtsp_transport tcp rtsp://admin:[email protected]:554/ch01/1

Configuration in Lovelace
- type: picture-entity
entity: camera.front_door_camera
camera_view: live

On the screen, it shows:
Preview of the Front Door Camera camera
It also has the footer with an Idle state.

If I grep the log from hass --open-ui for ffmpeg.core, this is what I get:
2020-05-14 12:15:48 DEBUG (MainThread) [haffmpeg.core] Start FFmpeg with [’/usr/bin/ffmpeg’, ‘-version’, ‘’]
2020-05-14 12:15:57 DEBUG (MainThread) [haffmpeg.core] Start FFmpeg with [’/usr/bin/ffmpeg’, ‘-rtsp_transport’, ‘tcp’, ‘rtsp://admin:[email protected]:554/ch01/1’, ‘-an’, ‘-c:v’, ‘mjpeg’, ‘-pred’, ‘1’, ‘-f’, ‘mpjpeg’, ‘-’]

Any help would be greatly appreciated. Thanks.


1 Like

I was missing the -i.

input should be:
input: -rtsp_transport tcp -i rtsp://admin:[email protected]:554/ch01/1