Fibaro Dimmer 2 or similar. How to use the second input channel?

On most of z-wave devices there is an option to attach a second button to control other devices. This is exactly what i wnat to accomplish in several cases - controliing for example Sonoff Relays. So how to find this second input? Today i connected the Fibaro dimmer 2 and it has like 12 entities. Which one responds to second input i can use in automatin rules?

light.fibaro_system_fgd212_dimmer_2_level_2_0
light.fibaro_system_fgd212_dimmer_2_level_2_0_2
light.fibaro_system_fgd212_dimmer_2_step_size_2_6
light.fibaro_system_fgd212_dimmer_2_step_size_2_6_2
sensor.fibaro_system_fgd212_dimmer_2_alarm_level_2_1
sensor.fibaro_system_fgd212_dimmer_2_alarm_type_2_0
sensor.fibaro_system_fgd212_dimmer_2_energy_2_0
sensor.fibaro_system_fgd212_dimmer_2_exporting_2_32
sensor.fibaro_system_fgd212_dimmer_2_heat_2_7
sensor.fibaro_system_fgd212_dimmer_2_power_2_4
sensor.fibaro_system_fgd212_dimmer_2_power_2_8
sensor.fibaro_system_fgd212_dimmer_2_power_management_2_11
sensor.fibaro_system_fgd212_dimmer_2_sourcenodeid_2_2
sensor.fibaro_system_fgd212_dimmer_2_system_2_12

Hi,
Why you dont test this out? I think its not a sensor, so it must be a “light” I have the same Dimmer but I’m only using the the S1 input on the Dimmer. So I think S2 is light.fibaro_system_fgd212_dimmer_2_level_2_0_2 because it have no function for me. Try this out.
Maybe you have to change some settings in the Openzwave control panel.

All you have to do is enable the scene mode for the dimmer 2 and then create an automation which picks up on the particular scene ID depending on how many times either button is pressed (check the manual).

Btw Don’t need to use ozwcp as you can send parameter changes via HA:

thx @mark.carline I didn’t know that.

You can configure scene mode in ozwcp in Parameter 28.

http://manuals.fibaro.com/fgd-212/

1 Like

Well this is pretty hard for a noob in z-wave. I have checked the parameter 28
Reading through the manual - it seems that we send parameter 1 to enable and than we will get that all fibaro dimmers 2 on s2 will have a scene id of 26 for a single push? So if i have 2 fibaro dimmers both will control scene id 26?

So yeah, just send this to enable the scene activations (this example is for my node 83):

{
"node_id": 83,
"parameter": 28,
"value":1
}

then just use an automation like this one to pick up on the different scene IDs (which are unique for each dimmer):

- alias: 13 Bedroom 3 Dimmer 94 Button 2 1xClick scene id 26
  trigger:
    platform: event
    event_type: zwave.scene_activated
    event_data:
      entity_id: fibaro_system_fgd212_dimmer_2_94
      scene_id: 26
  action:
    service: switch.toggle
    entity_id:
      - switch.everspring_an157_plugin_appliance_module_switch_19_0

Thank you for the script. So it looks like i can catch the event from a single dimmer? So it won’t be like pressing a button on any of the five (for example) will toggle the light?

I’m just using the second button to turn on/off a remote wall plug

Thank you everything working.
Wonder if you can use several scene types?

Tried like this with no success. All off never fires on triple click. Single click for entry light works perfectly

- alias: Entry light
  trigger:
    platform: event
    event_type: zwave.scene_activated
    event_data:
      entity_id: fibaro_system_fgd212_dimmer_2_3
      scene_id: 26
  action:
    service: light.toggle
    entity_id:
      - light.prihoz_spot
- alias: All off
  trigger:
    platform: event
    event_type: zwave.scene_activated
    event_data:
      entity_id: fibaro_system_fgd212_dimmer_2_3
      scene_id: 25
  - service: homeassistant.turn_off
    entity_id: group.all_lights
  - service: homeassistant.turn_off
    entity_id: group.all_switches
  - service: tts.google_say
    data:
      message: 'All off'

Looks like your missing the:

action:

For the all off

Sorry for that. Lost it during the copy/paste.
Well somehow the problem was in homeassistant.turn_off
Changing it to light.turn_off almost worked. Switched off all the lights EXCEPT for the dimmer3 - the one which triggered the scene and automation rule.
After changing group.all_lights to group.lights-where i added everything by hand - works perfectly. Strange behaviour.

I’m strugling with this.

This is my automation (created with gui):

  • action:
  • alias: lamp toggle
    data:
    entity_id: light.badkamer
    service: light.turn_on
    alias: test
    condition: []
    id: ‘1509637709605’
    trigger:
  • event_data:
    entity_id: fibaro_system_fgd212_dimmer_2_level_3
    scene_id: 26
    event_type: zwave.scene_activated
    platform: event

I did change parameter 28 to 1.

ozwlog shows this when i push the button:
2017-11-02 20:39:13.123 Detail, Node010, Received: 0x01, 0x0b, 0x00, 0x04, 0x00, 0x0a, 0x05, 0x70, 0x06, 0x0d, 0x01, 0x01, 0x84
2017-11-02 20:39:13.123 Detail,
2017-11-02 20:39:13.123 Detail, Node010, Refreshed Value: old value=0, new value=1, type=list
2017-11-02 20:39:13.123 Detail, Node010, Changes to this value are not verified
2017-11-02 20:39:13.123 Info, Node010, Received Configuration report: Parameter=13, Value=1
2017-11-02 20:39:13.123 Detail, Node010, Notification: ValueChanged

I don’t see it sending a scene.

Anyone got an idea?

1 Like

Please format the code.
Below is how i use it in automation

- alias: Bedroom Light Bra smthing
  initial_state: 'on'
  trigger:
  - platform: event
    event_type: zwave.scene_activated
    event_data:
      entity_id: zwave.zwave_bedroom_left
      scene_id: 22
  - platform: event
    event_type: zwave.scene_activated
    event_data:
      entity_id: zwave.zwave_bedroom_right
      scene_id: 22  
  action:
    service: input_select.select_option
    data:
      entity_id: input_select.bedroom_light
      option: "smthing"

@kipfel
Did you get it to work? I have the same kind of problem.

See the reply i gave. You can use zwave.scene_activated and read the code of the button switch. 18,22,24 e.t.c They are all laid out in fibaro dimmer 2 manual

I can’t see the scene_id in the logs, have changed multiple settings on the dimmer 2 but i can’t get it to work.
Using the s1 for a lamp and i want to use the s2 for a different lamp somewhere in the house connected to HA.

Got it wired with a “pulse” button, not the old on/off switch.

Parameters:
20: Mono-stable input (button)
26: 3-way switch function for s2 enabled
28: scene activated
32: on/off mode enabled (dimming is not possible)

Only got this in the log:

2020-11-09 11:29:23.447 Detail, Node003,   Received: 0x01, 0x0c, 0x00, 0x04, 0x00, 0x03, 0x06, 0x31, 0x05, 0x04, 0x22, 0x00, 0x00, 0xe0
2020-11-09 11:29:23.447 Detail,
2020-11-09 11:29:23.447 Info, Node003, Received SensorMultiLevel report from node 3, instance 1, Power: value=0.0W
2020-11-09 11:29:23.447 Detail, Node003, Refreshed Value: old value=0.2, new value=0.0, type=decimal
2020-11-09 11:29:23.447 Detail, Node003, Changes to this value are not verified
2020-11-09 11:29:23.447 Detail, Node003, Notification: ValueChanged

Thanks!