Fibaro dimmer association toggle light

I’m having an issue with 2 fibaro dimmers (version 2) that I can’t seem to solve. One of the dimmers is mounted normally behind a double toggle switch. It controls the connected light fine. The secondary switch is connect to the S2 output.
The second dimmer is mounted directly behind another light and because of that can only be controlled by association or HASS.

Now, I have associated the first dimmer with the second and I can toggle the second light on/off fine. The problem starts when I change the light through other ways, like switching it on using HASS. The second switch appears to ‘remember’ the old state and I’ll have to flip it twice to turn the light off again. I’ve basically tried all combinations of every thinkable configuration option for both dimmers, but this functionality seems unchangeable.
Basically all I want is for the first dimmer to send a toggle command instead of an on or off command. Right now the OZW log is suggesting an on command is send to the already on light.

Alternatively I could remove the association and work with scene changes, I suspect that would work fine, since I could just respons to both the OFF and ON scene ids, but I’d rather have the lights work if the server is not working.

Does anyone have any experience using the S2 functionality that can help me?

Did you ever get this sorted, sophof? I’m trying to set up a couple of Fibaro dimmers the same way, and finding the same issue. Any pointers would be appreciated! Thanks.

I’m not sure I understand the issue.
How are the light circuits configured ?
how have you connected the dimmers ?
These are gen 2 or gen 5 devices ?
How have you set the notify parameter ?
Are they both in group 1 with your controller ?
do you just want two lights to operate from the same switch ?
This seems overly complicated unless there is a physical separation or they are on a different supply/fuse ?

hmm, I’ve not been working on my system for a while, so I missed that I finally got some response :wink:
Anyway, I was afraid it was a bit too complicated for words, it’s a bit hard too describe and I can’t find anything online.

What I can add to maybe clarify the configuration is the following: the first dimmer is connected to the double switch. The second dimmer has no connection to any switch. This has to be done due to limited space behind the double switch (the first dimmer already didn’t fit without some modification).
So the second light can ONLY be controlled by zwave.
The second dimmer is associated to the first and therefore controlled by switch connected to S2.

Now it appears that the first dimmer sends ON/OFF commands when S2 is used instead of toggle, even though the S1 switch is set to toggle in the settings.
This becomes an ‘issue’ whenever the light is not changed by the switch, since the wrong command is send when using the switch.

These are both v2 fibaro dimmers (don’t know of any v5 and can’t find those on the website? so I’m not sure what you mean).

The obvious solution would of course be to mount the second dimmer to it’s own switch, but this is sadly not possible. Another solution would be to assign scene changes to S2 on the first dimmer and then have HASS handle the commands sent to the second dimmer. However, I appreciate the lights working without my server running more than I hate the double clicking (in case of system failure the lights need to keep working imo).