Fibaro Dual Switch plug

Hello again, everyone!

I’m trying to setup Fibaro Dual Switch, but experiencing some problems with it.
First was that one dual switch had about 10 instances in HASS (IDs 6_0, 6_0_1. 6_0_n, 6_0_10), but that issual resolved after I removed and added it again. I think I also held the button on the switch to reset it.

But now I have another issue. Before the switch was working as expected. I’m using toggle switch, and turning it on and off was natural. Switch it once to the opposite direction (DOWN to UP or UP to DOWN), and it switched the light. Not the best approach to use toggle switch with a wall plug, as often it resulted in inverted switch position, but that’s expected.

But now it seems that after reset it changed to the “button” mode. So to switch the light, I need to press the switch into DOWN position, and then UP again.

I checked the manual, and it says there that I can set zwave parameter 14 on the plug to change it’s behaviour (toggle\button modes). I tried changing it from hass, got no errors in hass and zwave logs, but nothing changed. I tried to print parameter 14, and then other parameters from 0 to 20, and they are all returned as none.

Is this something to do with OpenZWave being incompatible with Fibaro switches? Something that was mentioned in this thread? Issue with Fibaro FGS223 Dual Switch

Or is it some other issue?

If anyone knows anything about this, would be a great help!

I think you normally have to “wake up” your device, before it will accept any new config data. I have no idea how you do that with a switch tho’ :stuck_out_tongue: my sensor has a button I have to press 3 times.

To clarify things a bit you’re using a Fibaro relay switch, designed as an insert which is placed behind a conventional wall switch. From what I can tell you’re using the new Z-Wave Plus series Double Switch 2 (FGS-223).

FGS-223 does not have a Parameter 14. I recommend that you take a look in the configuration section of the digital manual or the manual you received in the cardboard box. You’re looking for Parameter 20 (Switch type).

The wall switch is only relevant to the relay insert. OpenZWave only sets the parameter, if necessary.

Mains connected Z-Wave devices are always “awake”. Manual wake-ups are only needed when configuring a battery operated device.

Ah I see :slight_smile: yep mine is a battery operated sensor.

Thanks for your reply.

Yes, it’s always awake :wink: Just to mention it again :smiley:

Mine is actually FGS-222, at least thats what the store I bought it from sells, as far as I can tell by their site, and FGS-222 (from what I understand, it’s an older version with older firmware) does have parameter 14. I’m not sure if there are any markings on the device itself? I will check it the next time I pull it out of the wall. But I believe it’s 222.

I will also try parameter 20, in case it’s 223.

But the thing is that, as I mentioned, I did try printing all parameters starting from 0 and up to 20, or something like that. Any firmware version has more than one parameter in that range. But HASS\OpenZWave returns them all as “none”.

Meawhile I tried printing parameters of my other switches, which are TKB Home, and they are like… inclousure. It’s actual z-wave switch, not a plug. They print their parameter values correctly. The same with AEOTEC multisensor, it does print it’s parameters correctly as well.

I overlooked your initial comment regarding the manual. Since that’s the case you seem to be using a FSG-222 and the manual I linked is of no use.

If I were in your situation I would stop Home Assistant, fire up OpenZWave Control Panel (OZWCP) and let it run through the node query. Once the node query has finished, verify the parameters by highlighting the node, click ‘Configuration’ and refresh the parameters. Then try changing Parameter 14 and verify the result by changing the state of the wall switch.

If OZWCP states the current value of Parameter 14 is already set to bi-stable switch type, try changing the parameter to mono-stable and back to bi-stable.

Thanks, I will try that.

However right now I’m a bit skeptical about it, I have a feeling that OZWCP will return all parameters as Null as well, just like HASS is doing it. Since, from what I know, HASS is using OZW’s functions and code anyway, right?

If the device is unresponsive or unreadable in OZWCP you can conclude that one of the bullets below is the cause of the problem.

  • Your mesh network has changed. The controller or the device might have a hard time transmitting the Z-Wave signal to/from the device.

  • You’re running a (very) old version of OZW. The device needs to be recognized properly within OZWCP to display the parameters. This isn’t likely to be the cause though, as the FGS-222 was added to OZW quite a long time ago.

  • Your most recent inclusion of the device resulted in errors due to long distance or wireless interference. A reinclusion, after exclusion, usually solves this. Use OZWCP to verify.

So, I still did not yet try it with OZWCP directly, but I upgraded hass to the latest version. Finally got the zwave panel there. To clarify - before I was just using commands from hass, like those with JSON data.

So, bullets:

  • Should not be the problem, I did not change anything in the network. I did change the wall switch, however. But then again, the rest of the network works perfectly fine, and i’m in a small apartment, they basically can reach each other with no problems.
  • How do I check version of OZW? And how to I upgrade OZWCP on hassbian?

I’m running OZWCP right now, device is there, recognized as 10 LBR Routing Slave Binary Power Switch FIBARO System Unknown: type=0202, id=4002 off 16:13:49 Ready

Under Current Values I see 3 “SWITCH” parameters, all OFF. Which is kinda weird, there are only 2 buttons :smiley: But at least no 10 like in HASS Frontend… However there’s “switch all” on this switch, maybe 3rd one is used for that? whatever.

Under Configuration - there is nothing there.

Under Information -

Switch All: 	
Powerlevel: 	dB
Set Powerlevel: 	Submit	
Test Node: 	
Test Powerlevel: 	dB
Frame Count: 	
Test: 	Submit	
Report: 	Submit	
Test Status: 	
Acked Frames: 	
Library Version: 	
Protocol Version: 	
Application Version: 	

The XML file for FGS-222 is not recognized which results in an unknown device with basic switching functionality within the limits of its Z-Wave design.

You probably need to upgrade python-openzwave.

Got it.

Could you, please, point me to the steps to upgradnig it on hassbian?

And thanks for your time and assistance :slight_smile:

Allright, I actually decided to flash latest Hassbian image, making a fresh install, after reading that they changed how ozwcp is installed in latest (or one of) version of HASS. From PyPi I believe.

So, I guess that means I’m using the latest version of ozwcp, right? At least fresh enough for FGS-222 to be recognized properly?

For now there’s no luck with this. Hass found all nodes, thankfully, but Fibaro switch is still in the same state as it was, unknown and with no config parameters showing up in zwave panel.

I guess I should try to re-add it to the network, but it’s really late here now, and I don’t think I can stay up any longer fixing this issue. Will try it tomorrow I guess.

Hi Michael,

3-4 months ago, an update of ozw (which I dunno) fixed my problem with the FGS-223. The update included a fixed .xml file for the association of the second relay.

I’ll suggest to flash a fresh Hassbian image (which you allready did), remove all your nodes and reset them and finally reset the zwave controller using ozwcp.

Yes, the more recent versions of ozw(cp) will recognise the FGS-223 correctly. You should be able to set the switch mode parameters using ozwcp.

I use the units in toggle-switch mode (that’s the default setting) because I have kept the orginal toggle switches of my home.

PS: when my HA is down or the nodes are disconnected, they sometimes behave like you describe. I think that’s a bug in the firmware of the FGS unit because it’s happening sporadically (one in 20 times).

Good luck!

Thanks, I ll try that.

@Stephan_Teelen ,

Hey, so, I did re-add the node. The FGS-223 and it still does not work :frowning: I mean, it works just the same, gives same identification, data, etc. And still no config parameters available neither in ZWave CP in HASS, nor in OZWCP. And I did restart hass after adding it.

I also have problems with 2 other FIbaro switches I have, another FGS-223 and FGS-211 (single switch). I just can’t add them! I do the same thing as I did with the first one, I bring my Zwave stick close to them, like less then 1m even, and nothing. Switches connected the same, and they do switch the light, but I can’t connect them to Hass\Zwave stick.

That’s damn frustrating. I’m thinking about just throwing those away, and buying TKB Home’s plugs, at least their switches work perfectly fine, like PERFECTLY, I did not have any issues with them at all, and they even expose their settings with pretty names to HASS’s ZWave panel. So I suppose their plugs should work the same.

Will go cry in the corner.

Ok, update.

I did add those two new unity by first removing them from the network. Seems that’s a thing with Zwave devices, sometimes they can add with errors, so you won’t see them, but to pair them again you have to unpair them first… Anyways, they are in.

Second thing - there’s a confusion in previous posts, regarding it’s actual ID. It’s FGS-222. Not 223.

So, 2 FGS-222 units and 1 FGS-211.

Now, the funny thing is. FGS-211 works fine now. It’s recognized, it has a name without “Uknown” in it, and it actually HAS CONFIG PARAMETERS in hass, available right away.

But BOTH FGS-222 units behave the same. They have 0 params available, and they are still listed as “Fibaro blahblah UNKOWN blah”. switch.fibaro_system_unknown_type0202_id4002_switch_12_0

Gotta say that my AEOTEC is listed similarly sensor.aeotec_unknown_type1a02_id0064_temperature_8_1.

Maybe I have to add them somehow ‘securely’? I read that it’s a thing with AEOTEC, though I did not need that, it works fine as it is for me.

Are you absolutely sure you removed the fgs-222s correctly? No dead nodes detected on your network (see OZWCP)?

When I want to unpair the fibaro units, sometimes I have to attempt unpairing multiple times. Please make sure you remove the units completely. Also be sure you don’t have any dead nodes in your network. If you attempt to pair the devices securely while they are not completly unpaired, you’re only making things worse. I even believe I also noticed devices being “unkown” when being added while not unpaired correctly in the past.

My controller is a plus usb stick on a raspberry pi 3. At the moment, the FGS-223 and the other nodes are included non-securely. But secure mode also worked just fine in the past.

Best is just to remove all zwave devices and reset the controller (cave: some controllers don’t support resetting, please google it first). Before resetting make sure you don’t have any devices left. After that, start pairing them. They should be added without problems.

NB. When you did reset the controller without first removing the node, it still thinks it is paired to the controller (but the controller doesn’t recognize the mode). You can unpair those devices nevertheless (its not required to be paired with the controller giving the unpair command). Be sure to unpair it multiple times just to be sure. You can also watch the controller state in OZWCP while unpairing the device if the command was succesfull.

Tried everything. Also check this thread with another issue with them, and the spamming issue: Fibaro FGS-222 and Switch with Light\Werkel

Today I just dumped them (well, in a closet, I’m not mad to just throw them away anyway :D), and bought TKB Home plugs, which also go under Philio brand. China either way. And. They. Work. Perfectly.

Like… I did not even have to press any buttons, once I turned the power on, the LED on them started blinking, and once I clicked the “Add” button in HASS it just added itself. Guess once turned on for the first time it’s already in ‘add mode’. So, neat.

Next, the toggle switch problem went away. They have another logic compared to Fibaro switched. In fibaro if I used toggle switch, turned it ON (UP) physically, then turned it OFF from HASS - the switch sort of inverted, staying in UP but turned off. So no I’d have to move it DOWN to turn it ON. And UP to OFF. Until I switch it again from HASS. Well, you know it.

But with these Philio switches, they use another logic. And I like it more. If I turned the switch physically UP (ON), then turn it OFF from HASS. Then I’ll need to first turn it OFF physically and then back ON physically. So it sort of fixes itself. So it’s like, if you move it DOWN (OFF) it will always switch to OFF. If you move it UP (ON) it will always switch to ON. Does not matter if it’s on or off already.

Then they also have power\current sensors. They cost less than fibaro (at least here). They come with WIRES in a box :smiley:

And they have all configuration parameters available in hass.

The downside so far is that LED on my physical switch is not working with them. But I did not yet check config params thorougly, maybe there’s something about it. With Fibaro LED potential was causing fibaro switches to perform irregular unwanted switching anyway.

So maybe it’s something with FGS-222.

I would mark them as Faulty with Hass (or just faulty), and would recommend buying either your FGS-223 (since you claim they work, I believe you, updated firmware should work better :slight_smile: ), or something else like Philio plugs.