Fibaro FDG-212 with Razberry

I have installed hassbian on my Rasberry. To control my Fibaro switches (two FDG212 dimmer, one relay switch) I use the Razberry zwave controller.

I am able to control all my switches/dimmers via the web interface of the Razberry.

However when I try to control them via Home Assistant I am not able to. Only the relay switch responds.

I have set HA to discovery and for the dimmers I only get the following light components:

  • light.fibaro_system_fgd212_dimmer_2_level_2_0
  • light.fibaro_system_fgd212_dimmer_2_level_3_0
  • light.fibaro_system_fgd212_dimmer_2_step_size_2_6
  • light.fibaro_system_fgd212_dimmer_2_step_size_3_6

None of them work when switching/clicking them in the HA user interface.

Since they work in the Razberry UI and the Fibaro relay works in the Home Assistant UI, I think I did not make any mistakes in my setup. Is there a configuration that I am overlooking?

Same here. Worked with HA ca. 0.38 but stopped working in the recent versions. I also had my Dimmer replaced because I suspected a hardware defect.
In my case I have a Aeon Labs stick and can control the dimmer via the ozwcp interface.
What changed significantly during the recent versions?

I eventually managed to fix it by adding the device as non secure device. Need to investigate further…


I did the same thing: added the dimmers as non secure devices. This worked for me as well!

The fibaro relay switch was already included as non secure, so that’s why it must have already worked for that one.

Thanks @nodomain!