Fibaro Flood Sensor Not Doing Anything

I’m using homeassistant with a Aeotec Z-Stick and recently paired a Fibaro Flood Sensor to it.
I added the z-wave configuration to the yaml, and tried configuring the sensor as well. I ended up getting two sensor readings on my homepage, but they don’t show much info.


I also tried to simulate a flood (I put the sensor on a plate and poured water onto the plate. The sensor lit up and beeped, but nothing on the homeassistant end. I even checked OZW_Log.txt and there was nothing new around the time of the simulation.
I’m not really sure how to troubleshoot this, any ideas?
If it’s helpful I can post some of my OZW_Log.txt and the zwcfg XML file.

1 Like

Are you using the Basic instruction set or Binary Sensor? I think you have to set this for binary sensor. Then reboot everything (Pi/Host and HA) and then be patient and wait for the new sensor entities to show up. You may have to restart HA a few times.

I’m afraid I’m not really sure what you mean by that. How can I tell if I’m using the Basic Instruction Set or the Binary Sensor?

Edit: I actually just waited a while this time and some of the sensor entities showed up. I see this now:

I tried to simulate flooding and a temperature change by putting the sensor in water and in the freezer (not at the same time) and neither one had a change in state.

You’d see this in the config in the open zwave control panel. Looked at your screen cap; I would do a few more restarts of HA and see if the names start to settle out.

Would restarting a few times help with the states updating? Now that the right sensors are showing up the values don’t change during my tests unfortunately.

Honestly don’t know, that’s just my gut reaction. It’s not going to hurt things.

@Inbl I’m trying to use this same sensor and seeing the same behavior. Did you ever get this straightened out?

Nope! It’s been very frustrating and I’ve pretty much given up on it working.

I’m having same problem. I’m only seeing Temperature changes, but other sensors aren’t doing anything including water/moisture/flood detection. I place the sensor on a wet paper towel, it beeps, and OZW_Log shows the event. However, HASS dashboard shows nothing, nor does Node-red show anything.

Clearly there is a incompat issue with HASS since it’s not interpreting the event. properly and bubbling it up.

Anyone else get this to work or have a water/flood sensor that does work? I’m well within my amazon return window :slight_smile:

I have it working, or at least it worked a few versions ago…

If I remember correctly it’s a sensor called “flood” that will trigger when the unit sences waters. You should see two of those as the unit has an port for an extra sensor.

It might go to 2 when triggered, but I can be mistaking, I don’t have access to my config at the moment…

Have you tried to unpair/pair again?

I have this sensor paired with my Vera Plus and I have the same problem. Temperature is reported, but flood sensor is always off. Despite seeing the alarm in Vera.

You can get this working, but the binary sensor wont work as expected. You have to check the state of the flood alarm instead, it might be two of them pr sensor. This one should change number when flood is detected. This works with Fibaro Flood Sensor.

Here is a automation you can use:

- alias: Flash red lights on kitchen when leak detected under sink
    platform: state
    entity_id: sensor.kjkken_skap_uvask_vannsensor_flood
    to: '2'
    - service: light.turn_on
        entity_id: light.hue_lightstrip_plus_1
        brightness_pct: 35
        color_name: red
        flash: long
    - service: notify.xxxx
        message: >
          "Leak detected under sink!"

@anaxyd How did you know to reference the value of 2 in that automation? I can’t seem to find a list anywhere?

These docs reference the alarm_level sensor entity, but in this case the values also apply to the flood sensor entity. A value of 2 means “Water leak detected (unknown location)”.

The full list is available here. The flood entity will correspond to the Water Alarm (value 0x5).

1 Like

Thank you @freshcoast!