Fibaro metered power plug

Hi all,
I’m a newby, and testing around. I have a raspberry pi 4 (8gb) with Home Assitant running on it. I recently bought a aeotec gen 5 z-wave dongle and a Fibaro wall plug (FGWPF-102). I manage to set things up, but I can’t get the switch on/off working. When I klick on the button, after a few seconds, it returns to its original state (and nothing happens to the plug itself). As the power meter works as it should, I can’t imagine there is a connection problem.
I browsed around on the net to find a solution, but couldn’t find it.
Can somebody help me out here? Give me hints and tips, or show me the way for a solution.
Thanks in advance.

PS. I connect with the Z-wave JS integration.

Have you checked in the Configuration -> Devices page for your wall plug that there are no hidden entities? I am thinking that there might be more than one switch entity and the system has enabled the wrong one by default. It’s a guess, but I have read several comments about that sort of thing happening.

Is it possible that the FGWPF-102 model is not yet recognised properly by Z-wave JS? I have 7 of the older FGWPE/F-101 model, and they are all working correctly in my HA setup using the Z-wave JS Add-on. For example:

Thanks for the help. In the meantime, I tried some stuff. I removed the z-wave js add-ons and the z-wave js integration. I rebooted the raspberry. Afterwards I reinstalled The Z-wave JS addon, the Z-wave JS MQTT addon and the Z-wave JS integration. This brought me back to the state I was. And now the switch is working like a charm. Yeeha.
Unfortunately, when I now look in the Zwave JS to MQTT web UI, there is nothing. In the Zwave JS integration, the devices are there. Any ideas on this problem?

Ok. Again a few steps made. The Web UI interface problem was caused by the fact that I also had the Zwave JS addon running. Stopping this addon made the Zwave JS to MQTT web UI working.

But I also found the trigger for the powerplug on/off not working. In the Web UI, I added a name to the power plug, and restarted HA. Now the on/off was not working anymore. I removed the name, and it worked again. Can we talk about a bug somewhere, or am I missing something?

Hi BertCa,
As a newby (also) I am wondering how you made the FGWPF-102 plug appear as a Device anyway?
Do you have a link to a description how to achieve that?
Thanks, Chris

Hi Chris,
As a matter of fact, after my last post I didn’t do much with Home Assistant anymore. The devices are visible via the Zwave JS addon and the Zwave USB controller (piece of hardware). But as mentioned above, I made it with trial and error and some stuff I read on the internet. And no, I did not document it - so whenever I need to reinstall, I will have to call Houston telling them I have a problem :wink: