Fibaro multi sensor - problem lowering temperature offset

On a FGMS001-ZW5 Motion Sensor, setting ‘66: Temperature offset’ 0-100 works fine, but setting it within the range for subtracting degrees from the actual temperature fails. Eg. setting 65525 to subtract 1 deg C from actual is not accepted.

The value to be added to the actual temperature, measured by the sensor (temperature compensation). Available settings: 0 - 100 (0 to 100C) or 64536 - 65535 (-100 to -0.10C) Default setting: 0

Any ideas? Is this a problem with the sensor or OpenZWave or HA’s input field?

I have not yet tried this setting in Home Assistant (since my sensor is failing and waiting for a new one), but I had similar problems when running a different software. I managed to change the offset do negative when using minus-sign. For example the offset value was set to -10.
I cannot remember how to translate the values to actual degrees, but at least try it out since it worked for me.

Thanks. I’ll give it a try this afternoon :slight_smile:

Got a late response from Fibaro support, where they were able to reproduce the problem. They were able to sometimes get the value to stick on the sensor, which I have repeatedly not been able to do. Will try again.


It seems the device would sometime decline the request, but I was able to change it many times.

I have decreased the value by one degree by setting 65526. See the example attached.

As I said, the device would not always accept the value and therefore I will report to our Developers asking to fix it.

Thank you for reporting the issue.

I was unable to set values as described in response from Fibaro support in Home Assistant. However, experimenting further with negative numbers provided a solution. A value of -1 equals -0.1 degC.

Having the same issue; the Fibaro sensor temperature is 2 degrees higher than what it should be. I figured I would set the Temp Offset to 65515, however it always reverts back to 0. Did you manage setting yours properly?

Sorry for late reply, been off for a while. I managed to set the offset as described in my last post. Entering a value of -1 offsets the temperature -0.1 deg, so -20 offset would lower the temp readout 2 degrees.