Fibaro RGBW controller not updating status when manually triggered

Yesterday I got my Aeotec zwave dongle and I added my Fibaro RGBW controllers. Whey show up nicely in dashboard as 6 switches:


I’m not sure what ...level and ...level_3 switches do, but the rest of them turn on my lights.

I have 2 problems:

  • when I turn off the light with a toggle in UI, the switch goes off and then back on, but the light turns off. How to make it stay off?
  • if I manually press the toggle switch on the wall, it will turn on/off the light, but the UI won’t update. Should it update itself (as is, does rgbw controller support instant change pushback(?) or do I have to enable frequent pooling to get the state?
  • anyone use any other RGBW controller with support for manual toggle/momentarly press switches?

Thanks, Matej

For the first problem try using different light entity from the list you’ve mentioned.
Re. second problem: is the physical button turning off the dimmer (or the power supply) or is it wired to Sx, S1, S2 on the dimmer. If it is the former then this might be the issue as this dimmer is not supposed to be turned off via cutting power to L.

Hey, thanks for reply.

I tried using all the entities and there is the same problem. I think entities 4-7 are RGBW outputs, since each of them turns on a different light. level doesn’t do anything and I think level_3 just turn on the last powered light.

Each switch is wired to the coresponding input, so I’m only switching on/off the output, not the whole controller.

Wiring diagram (not exact, but I’m just clamping GND and input channels and each RGBW output is a different light):

I had this dimmer and it worked just fine. I suggest to inspect HA and zwave logs when you toggle the light using physical switch. There should be an indication that state of something has changed. If there is nothing then it is a bigger problem.

OK, I’ll have a look at the logs and see if I can find anything useful there.

Did you have polling enabled for this dimmer? I’m not sure if it supports notifying HA that something has happened or does HA needs to pull the state.

According to this link: and, this dimmer doesn’t have Association listed under Controlled command classes, so I guess I’ll have to enable pulling to make it work.

I added polling_interval and device_config section to the config file and it’s not working. I need to comment out one-by-one to see what is the minumum config I need for the system to work.

Example of config:

  usb_path: "/dev/ttyACM0"
  network_key: !secret network_key
  polling_interval: 30000
      polling_intensity: 1
      refresh_value: true

Hi mmz

Some time has passed, so please forgive me if you have moved on from the RGBW dimmers.

I am experiencing the exact issues as you have described.


  • HA not updating when manual switch used
  • HA not reflecting correct brightness level after change (represents previous value. ie: one step behind)
  • And general confusion as to what those additional “level_” 's do…

Did you have any success getting these to work with HA?



Hey there,

yea I think my system works OK now. I did however had to enable manual polling, the sensors are not pushing the values to HA.

I don’t have access to HA right now, but I think I only setup polling_interval in the end. Will check when I get home if I don’t forget.

At least that is encouraging.

I have the status updating now using polling on the relevant “level” / channel. Can be a bit confusing when using the slider to adjust dimmer level - jumps around all over the place (displaying the previous value). This updates when polled though.

I also can’t set my “IN/OUT” mode (Option 14). Refuses to take the value calculated by the Fibaro advanced config for this parameter. Did you have any problems with this?


I have this in configuration.yml:

  usb_path: /dev/ttyACM0
  network_key: !secret zwave_network_key
  polling_interval: 30000
    #   polling_intensity: 1
      refresh_value: true
    #   polling_intensity: 1
      refresh_value: true

It does work suprisingly well, but I also have a jumping slider, specially when I power off the lamp.

As far as I tried, it looks like it does take my “IN/OUT” parameter. I set a new value, clicked Set config, changed to another option and then back and I could see the new value.