Fibaro RGBW Controller

Tags: #<Tag:0x00007f7399be9d08>

Hi All,

Does anybody has a Fibaro RGBW module working (complete with colorwheel) in ha?
There are some topics about this, but i can’t seem to find a definitive answer is this is working.

I have a led strip in my living room, which is part the main lighting for my living room.
I can turn it of and on change the brightness, but i am unable to change the color.
I have tried to create a scene to change the color by setting the rgb_color options but doesn’t work

I somebody has this working i would like to check there config or maybe there zwcfg.xml

Thanks!

Did you get this working?

I have the Fibaro RGBW controller set up.
With a little tinkering I now have a group simply called “light” with 6 switches.
All had the same name, but i have now identified them as R,G,B,W and renamed them accordingly.
The remaining two I haven’t figured out.

I have noticed that using the switches doesnt work, however clicking on the name and adjusting the brightness does.
Also clicking on the colour wheel after clicking on the name, causes the other colours to light up to the same brightness

Just started to look into trying to add the brightness sliders to the group instead of the Boolean switches.

I have replaced my fibaro rgbw led strip with a xiaomi light strip now which works perfect.
When i have some more time i will investigate more…

Home Assistant generates the following six entities for me, which as you say, share one friendly name which makes it impossible to distinguish on the dashboard.

light.fibaro_system_fgrgbwm441_rgbw_controller_level_33_0
light.fibaro_system_fgrgbwm441_rgbw_controller_level_33_0_2
light.fibaro_system_fgrgbwm441_rgbw_controller_level_33_0_3
light.fibaro_system_fgrgbwm441_rgbw_controller_level_33_0_4
light.fibaro_system_fgrgbwm441_rgbw_controller_level_33_0_5
light.fibaro_system_fgrgbwm441_rgbw_controller_level_33_0_6

I used customize to rename them as follows, in configuration.yaml:

homeassistant:
  customize:
    light.fibaro_system_fgrgbwm441_rgbw_controller_level_33_0_2:
      friendly_name: RGBW Light - Main
    light.fibaro_system_fgrgbwm441_rgbw_controller_level_33_0_3:
      friendly_name: RGBW Light - Red
    light.fibaro_system_fgrgbwm441_rgbw_controller_level_33_0_4:
      friendly_name: RGBW Light - Green
    light.fibaro_system_fgrgbwm441_rgbw_controller_level_33_0_5:
      friendly_name: RGBW Light - Blue
    light.fibaro_system_fgrgbwm441_rgbw_controller_level_33_0_6:
      friendly_name: RGBW Light - White

the first entity does not seem to do anything consistently so I just excluded it, as follows, in zwave_device_config.yaml:

light.fibaro_system_fgrgbwm441_rgbw_controller_level_33_0:
  ignored: true
  polling_intensity: 0

Note that the “33” in the entity names is the devices node_id on my z-wave network which will be different for you, the rest of the name should be the same.

2 Likes

Thanks for this, I used it to validate some of my own settings, and like you ignored the _0 entity.

In case anyone else comes looking for more info, here are some of my other findings…
It looks like the Entities mentioned for RGB and W and be largely ignored for basic usage.
Using main and its colour picker leads to:

  • RGB being used for white if only brightness is set
  • W being used if a “white” is chosed from the colour picker (i.e very top row).
  • RGB are blended in if a “less white” (or lower in the picker) colour is added.
  • You will notice that as colours are mixed, HASS will switch on the other channels on the dashboard.
  • The same channel switching occurs when you turn say green to 100% rightness and then click on its colour wheel, that is, the other channels are enabled with brightness set to hit the desired colour.

This means that there is a lot of repetition in the console and for the sake of simplicity your HASS web portal can be cleaned up for human driven changes by hiding RGB and W and leaving main. The specific channels can still be used via api/config to call specific combinations, but based on the below, this also might be unneeded.

Contrary to what you’d expect, using a snippet like the below (3_0_2 is my “Main”) , you actually end up with the white bring composed of RGB and not W. if however you set RGB to 255,255,255 and white to 0 it uses the white channel and not RGB, which feels a little backwards.

{ “entity_id”:“light.fibaro_system_fgrgbwm441_rgbw_controller_level_3_0_2”,
“rgb_color”: [0 , 0 , 0 ],
“white_value”: “255”,
“brightness”: “120”
}

This isn’t a major issue, and I it just means I’ll need to call an RGB code to get my warm white on, instead of using a white level, and adding an RGB code to tint

1 Like

NIce reading something about Fibaro RGBW controller again. I was wondering if there are some nice scripts to run for the RGBW modul. Or maybe someone already invented something nice? AFAIK Vera has scripts for RGBW …

Since this was the first hit on RGBW fibaro on google. Just a note, if you don’t see the color picker wheel, you have to select the main device (the first item) and turn it on before it becomes visible. You don’t see a color picker wheel when the device is turned off.

Any reason we couldn’t simply leverage the W channel for the overlap? In other words, take the minimum value between RGB and simply convert that to a W value.

Ideally we make this a toggle of some sort, but it should help extend the life of the LEDs themselves.

Also: when hooking this up to a warmwhite LED channel, the colors can actually be a bit different, so ultimately there could be quite a bit of flexibility.

I tried your suggestion but it didn’t help. I turned on every ‘light’ from my Fibaro RGBW controller, but don’t see a color picker wheel.
Do you still get a color wheel?

I still get the color wheel… see

You need to find the one that does brightness, perhaps that is it.

Just finally figured out how to convert this controller from RGB toggles to an RGB controller that gets the color wheel picker (and also exports a color control device to Homebridge).

Go to your Zwave settings, find the device, go to Node config options, select parameter six. Documentation for this parameter (and the rest) is at http://manuals.fibaro.com/document/rgbw-advanced-parameters/. Selecting “Normal (RGBW) - COLOR_CONTROL_SET” seems to do the trick. Note that I had some trouble getting this setting to stick, but after a few tries it seems to have stuck around.

57 PM

It does make sense you cannot set color if brightness is 0. In practice it is not handy. My setting was btw on Normal (Dimmer) Basis set etc…

p.s. on the new version of hass there is a new color picker wheel. https://home-assistant.io/blog/2017/12/03/release-59/#color-picker don’t know if that will also help in this case.

How is everyone doing with this controller? I want a controller that can be controlled by a switch physically connected to it and I prefer zwave over zigbee, so this looks perfect, but I need to know that the above issues have been solved… Is anyone happily running the Fibaro RGBW with hass?

Otherwise, does anyone know another RGBW (or even better RGB+CCT) zwave controller which can take input from a physical switch?

Would be great also to be able to control the white color temperature.

I still have a bunch of switches. I think it should just be 1 switch with the color wheel. Now it just ruins the overall experience in HA with so many switches.

I have the RGB controller available with a colour wheel in hass, although it’s exposed through vera (ie. not through a direct zwave stick). While I can use the colour wheel and make a selection the actual colour selected often seems to be different (eg. choose pink and get green). I haven’t done any troubleshooting yet, but it seems to work fine via vera, so it should be able to be fixed.

BTW: I don’t use a physical switch, just the hass/vera controls.

1 Like

I’m using a couple of these and they are finally working OK with Config Option 6 set. Setup is a pain in relation to identifying the various channels but once it’s done it’s fine. However I have now setup a few H801 WiFi RGBWW controllers with ESPHome and it’s a much better (and cheaper) solution.
These do not have a switch input to control them, so I just use a separate Z-Wave switch to turn them on and off.

1 Like

I’m having this same issue with Vera where the colour is not reflected correctly in the Hass front end. Did you ever manage to get a solution to this?
thanks

Hi everyone. I have the same problem with fibaro RGBW.
It works incorrectly. I have color wheel, but when I am choosing a color, only green or blue is available. Did someone ever manage to get a solution to this?

Have you set config option 6 for the device to Normal (RGBW) - COLOR_CONTROL_SET?
If you have, go back and check it as it doesn’t always save it correctly in my experience.

Yes, I set this parameter. Unfortunately this didn’t help me.
For example, I choose red color and this color lights up in the room, but on the color wheel I see green color.