Fibaro roller shutter 2 only goes one way (FGRM222) / roller motor dummy questions

Recently I bought a Zemismart roller motor of this type:

From my previous apartment, I still had a roller shutter v2 lying around gathering dust, so I gathered that I could reuse that with this motor.

I hooked everything up, pressed the “add node” button in home assistant --> zwave, an then pressed the b button on the roller shutter for 14 seconds, which should, according to the manual reset the device and put it into inclusion mode.

This worked, and I get 2 devices in home assistant:

  • cover.fibaro_system_fgrm222_roller_shutter_controller_2_level
  • cover.fibaro_system_fgrm222_roller_shutter_controller_2_switch

The first one shows controls for up, down and stop and a slider to set the position.

I tried the controls, and noticed that the motor will only turn counterclockwise when I press the down button or move the slider, I can’t press the up button.

I tried to to a calibration by executing command 29:Forced roller shutter calibration, but that just made the motor spin counterclockwise endlessly while the green led was blinking in the roller shutter.

Since I had the forest atlantis motor that I originally used with the roller shutter still lying around, I connected that one instead of the zemismart motor, but unfortunately, the result was the same.

Any idea what could be the cause of this problem?

I connected the roller shutter motor wires to 01 and 02 on the module, and connected the null line to it, while also connecting N and L to the module.

I also tried to invert the motor wires, which should normally invert the direction of the motor, but when I do that, the module only makes some clicking sound and the motor does not move at all.

I did some more fiddling around to figure out the problem.
I thought I could test the zemismart motor without the Fibaro module to see if it would work in both directions.

According to the documentation, it should be wired like this:

In the Netherlands we have slightly different wire colors:

L - Brows
N - Blue
ground - yellow

so I hooked it up like this:

and the motor started running. I then swapped the black wire for the red wire, expecting it to run the other way

unfortunately, nothing happened.

I then picked up my forest atlantis motor that I knew was working (at least 2 years ago) to see if the zemismart motor was faulty or that I was just doing something wrong.

I first hooked it up like this:

and it started running. I then swapped the black wire for the brown wire, once again expecting it to start running the other way:

but also with this motor, nothing was happening :fearful:
Now the question is: am I just doing something stupid? Or did I maybe destroy the motors with the (faulty?) roller shutter?