Fibaro Universal Binary Sensor FGBS001 not working when upgrading Z-Wave JS to 0.1.16


After upgrading Z-Wave JS to 0.1.16 from 0.1.13 my Fibaro Universal Binary Sensor FGBS001 has stoped working. After downgrading to Z-Wave JS 0.1.13 it works fine again. But back on Z-Wave JS 0.1.16 again no reaction when trickered.

Any suggestion on how to report this or how to fix it…?

Best regards Thomas

You might need to have the node-zwave-js project update its device config file, such as in this issue:, due to changes in v7.0.1.

You would need to provide a zwave-js debug log that shows the device reporting Basic Set commands and provide it to zwave-js. For reference, OZW implements the same config setting.


I have the same problem over here, not only with the fgbs001 but also with the fgs222
Did you report the problem ?

I want to help but don’t understand how to report


Same problem with the Fibaro FGBS-001 in my Z-wave JS to MQTT configuration.
Yesterday I did an update to 0.11.0


I have not reported it yet, and haven’t tried reporting it before, but hope I have time to figure it out sunday.
I also have an Aeotec Extender 6, that sundently appeared as light bulb… some time ago.

I kind of hate these integrity issues with z-wave definitions that used to work…
Anybody know how this happens… I have a feeling it is a bit to easy to brake a lot working devises for a lot of instalations. And I can not opt out on upgrading a device difinition, I have to take the hole package. I really like that Z-Wave JS is moving fast, but I can’t have my setup break.

All in good spirit :slight_smile:

I had the same issue and tried applying freshcoast suggestion above by adding the enableBasicSetMapping, and this fixed the issue.

See this node-zwave-js pull request


Super, thanks @XMaarten and @freshcoast

I would love to see a tutorial on doing this, including testing it… If anyone had that…

Could it also fix the same problem with fgs222 switch?

Hi @2mmaz, the pull request was just approved by AlCalzone so I suspect that this will be included in the next release soon. I fixed it on my system by opening a shell to docker, and fix the mentioned file by adding that extra line, and restarting node-zwave-js.

1 Like

@Aleksei_Piatkin, maybe! You could try adding the same line to fgs222.json

1 Like

I managed to go into the container’s shell and edit the config file… could you give me a hint on how to restart node-zwave-js? restarting the container seems to reset everything

I have the same problem, just install the zwave js mqtt and now the fgbs001 not update the sensors, if i do it bij manual refresh it gone good. also the shutter 2 isn update when manual is used,

I too have the same problem. From what I read above it should have been added a long time ago (April) but it still does not work for me. Maybe somebody can help me find the file ? I am running HA on a Blue.

Thanks in advance

I have the same problem here. Strange thing is the UBS stopped working when I tried to install it as a new node as i was adding a new sensor to it. I have four others that are still working fine. so it must be when its being setup at inclusion that is the problem If i have to install them again they will fail to return the value of the binary sensors. any idea when this will e fixed. Also can anyone tell me how to downgrade to Z-Wave JS 0.1.13 from the latest release as it seem to work in that version as 2mmaz post said . I am running home assistant on a pi 4.

I’ve also got one that doesn’t work properly, How and where do you find the files to change?

Hi Guys,
I’m new here, just installed HA this week and migrated all my devices over from Domoticz. It was going so well, I moved 40 Z-wave devices and 24 Zigbee devices over. Everything was working great…and then I tried the 2 Fibaro UBS’s and its a different story :frowning:

I have read the above but have no idea how to fix it. Would some be able to help me please? The UBS’s conect to my alarm system to perform actions based on the Full Set/Night Set or intruder status, so play a big part in my home.

Thanks in advance


Still looking for a solution to this if anyone is willing to offer one? I switched one of the sensors back to Domoticz and it works fine on there. Looking at using MQTT and node-red to bring the info over to HomeAssistant as an interim solution but ideally want to run only HA.

Updated to Z-Wave JS to MQTT 0.30.0 and my UBS’s are working again .The binary sensors are changing ect. you must remove the device and then start inclusion again and then the device will work.

Thank you so much! Just tested it and it works :smiley:

Time to decom Domoticz (again! lol).