Files still there, but Docker container gone? Help, please!

Because I couldn’t access the HASS.IO tab anymore, I tried restarting (the Ubuntu server VM containing it), after which my entire installation stopped working and sudo docker ps -a only gives me this:

e9eaa67e5574 homeassistant/amd64-hassio-supervisor “python3 -m hassio” 3 seconds ago Created hassio_supervisor

“sudo docker ps” shows nothing running at all

I don’t understand what happened and have lost all functionality, please help :frowning:

I tried “docker restart hassio_supervisor” and received this error:

Error response from daemon: Cannot restart container hassio_supervisor: error while creating mount source path ‘/usr/share/hassio’: mkdir /usr/share/hassio: read-only file system

is your vm disk full?

I don’t think so, sysinfo when I log in to Ubuntu says “Usage of /: 37% of 44GB”

I backed up and deleted the home-assistant-v2.db just now, it had grown to over 8GB and I know it normally gets recreated automatically, but a reboot did not do that…

The db file doesn’t get recreated on boot.

Hmm, that’s unfortunate…so I guess I should put it back.

If you delete it, it will get regenerated when Home Assistant starts, but by default it doesn’t just delete itself and regenerate on reboot.

I see, OK, so I won’t put it back, but how can I start HA? :frowning:

It seems that what’s going on is that the Supervisor container (which is the one that creates the others, no?) keeps trying to create itself and failing…

I don’t know. I don’t use hassio for a multitude of reasons.

I use normal Home Assistant Docker image.

This is extremely weird…I went back to a VM snapshot of 0.77.3, which seemed OK except for the fact that my HASS.IO tab would not show me an upgrade button to 0.80.2.

For a few hours yesterday it was OK (including the Telegram notifications which had stopped working on my 0.80.0 version), after which it started exhibiting the same problems as my previous 0.80.0 version!

The log shows:

  • Cannot connect to host ssl:None [Try again]
  • Client error on api app/entrypoint.js request Cannot connect to host ssl:None [Host is unreachable] - this also makes my entire HASS.IO tab unusable again

I’m afraid that if I restart it will do the same thing my 0.80.0 install did, i.e. stop working completely.

At this point it looks a bit like a networking problem, but I can still reach the normal https duckdns link, so what could be the cause??

I’m tempted to try an installation of Home Assistant in a different VM without Docker at all (if that’s even possible), I really don’t like the extra stuff that needs to be done because I’m running in Docker…I just wonder how upgrading works in such an environment

If you run hassio, you are running Docker. End of story. :wink:

I was thinking of regular Home Assistant, not HASS.IO. However, it seems like even that one runs in the Python virtual environment, so would probably create challenges of its own, including with updates.

At the moment I managed to get back to the 0.77.3 VM snapshot again, used a HASS.IO snapshot to go to 0.79.1, where, knock on wood, it has been relatively OK so far.

It does have some issues, though…in the HASS.IO tab it says I have an update available, to 0.77.3, lol. I also was not able to use 2FA anymore on my account, so am currently operating with the API password. Let’s see…

This is why I run just straight Home Assistant on Docker. No HASSIO, no python venv/dependencies, no issues with it at all.

Except for the Home Assistant bugs (which are usually documented well), the docker method has been solid for over a year.

1 Like

I have been running for 4 months with no major incidents that were not self-inflicted or in the release documentation, but I have no idea what happened now, I might just need to hose everything at some point and start fresh (except for the Z-Wave config, which seems transferable anyway).

If doing that, I might do what you did…how do you upgrade, btw? And do you not use any of the addons? I only use DuckDNS (which will be replaceable by Nabu Casa soon enough), Configurator (for when doing some tinkering from work) and Samba, so I guess they wouldn’t necessarily be an issue.

docker-compose pull && docker-compose down && docker-compose up -d

None of them add any value to my system. I don’t need SAMBA because I use Syncthing and work locally on my files. I have my own VPS on Digital Ocean and run my reverse proxy there, so it handles certs, and domain stuff.

1 Like

That sounds pretty great, I think I’ll use this crisis as an excuse to fire up another VM with an environment like yours and thus have TEST and PROD environments :slight_smile:

What guide did you follow? What distro do you use, Ubuntu Server?

Ah, I see you posted a full guide in your link :slight_smile: Thanks!

I never had a guide to follow.


I am at my wit’s end and really don’t understand what’s going on here…before restarting the VM, this is what my “sudo docker ps” looks like:

After restart, there are no containers at all, not even with --all, it’s like the entire Docker setup is gone.

I tried your stack, btw, and gave up after grappling for hours with the SSL issue (a common theme in your thread, I saw), returning to HASS.IO. I installed it using the regular guide, on a fresh Ubuntu Server 18.04.1 install, so WTF, I just don’t understand what I’m doing wrong.

Oh, and as if this wasn’t enough, my Z-Wave stick is acting up suddenly, it is seen by ls /dev, configured in HASS.IO, worked fine before the latest HASS.IO restart, now it simply doesn’t work and the only error I get in the log is “Z-Wave not ready after 300 seconds, continuing anyway”.