Finally! Raspberry PI 4 boot from SSD, no MicroSD required!

Well for you guys who would like to try I wrote a short guide and maybe later I will add installing HASS.core into it. Anyway without further due

1 Like

Pretty much any standard Usb Mass Storage device should work, I believe.

@repvik I did similar tests by adding to the HassOS 1st SD partition (hassos-boot, where there is also a config.txt file) the bootloader files of an “upgraded” Raspbian image which boots correctly directly from SSD (no SD), but I messed something or that isn’t enough to complete the HassOS boot process.

Yesterday I also wrote a short guide for myself and who may be interested.
Feel free to cherry peek what you want.
Sorry I don’t have a blog, so it’s PDF :frowning:

EDIT: new working link.

1 Like

“Link no longer available” :cry:

Today I successfully used the aforementioned “boot from SD and run hassio_data on a SSD” technique which gives right now:

  • minimal wearing impact on the SSD;
  • great speed boost;
  • works on all RasPI models without any bootloader upgrade.

About this technique, instead of a dd + resize I prefer to do a full ext4 format of the SSD and use rsync (or some other logical copy method such as Midnight Commander) to copy the HassIO data files from the just renamed hassio-data-sd partition on the SD to the hassio-data partition on the SSD.

Just my 2 cents waiting for the HassOS native SSD boot on the RasPI4 :wink:


Updated, thanks.

For those of you having problems with your USB enclosure (uas error’s) ont he USB 3 ports, have a look at : [Raspberry Pi 4 USB mass storage beta]

I ran into UAS problems/erros when using an Icybox (JMicron JMS578 chipset). A replacement enclosure based on the AsMedia ASM1153E worked without a hitch.

It looks like U-Boot loads, but it probably can’t load its env-settings. Looking at boot.scr:

part start mmc ${devnum} 6 mmc_env
mmc dev ${devnum}
setenv loadbootstate " \
    echo 'loading env...'; \
    mmc read ${ramdisk_addr_r} ${mmc_env} 0x20; \
    env import -c ${ramdisk_addr_r} 0x4000;"

setenv storebootstate " \
    echo 'storing env...'; \
    env export -c -s 0x4000 ${ramdisk_addr_r} BOOT_ORDER BOOT_A_LEFT BOOT_B_LEFT; \
    mmc write ${ramdisk_addr_r} ${mmc_env} 0x20;"


I cannot load the PDF. I get issues with Chromium and FireFox.
Maybe consider another source like dropbox?

Thank you!

Chromium example …

Your connection is not private

Attackers might be trying to steal your information from (for example, passwords, messages, or credit cards). Learn more


ReloadHide advanced normally uses encryption to protect your information. When Chromium tried to connect to this time, the website sent back unusual and incorrect credentials. This may happen when an attacker is trying to pretend to be, or a Wi-Fi sign-in screen has interrupted the connection. Your information is still secure because Chromium stopped the connection before any data was exchanged.

You cannot visit right now because the website uses HSTS. Network errors and attacks are usually temporary, so this page will probably work later.

@stevevanhoyweghen and all, here is a Google Drive link, just verified on my Arch+Firefox box:

On the same Arch+Firefox box I still don’t have problems with the link:

1 Like

Thank you! Much appreciated.

WARNING: This EEPROM is buggy (I know it’s beta).
I’ve reverted to ‘Boot from MMC with root FS on USB’ after a total meltdown.

Everything was running smoothly (as regards Raspbian anyway) until I needed to reboot the Pi and it failed to come back up. Powering on with just an MMC failed and I didn’t get the four flashing green LEDs with no boot media. Diagnosis: corrupted, or buggy, EEPROM.

I restored using the procedure at: and reverted to the stable EEPROM, before configuring ‘Boot from MMC with rootfs on USB’

1 Like

It looks like we are ALL stuck in the same frigging place trying to boot HassOS from an SSD.

After multiple tries and finally a new SSD enclosure w/ USB 3.0, I’m also here during boot from USB SSD ( booting HassODS on the SD card in a USB reader works just fine) :

start4.elf is not compatible.

bummer. my Pi3 isn’t up the task of running home assistant any longer. and I’ve already burned up 2 SD cards. I was really hoping someone would have solved this by now. Guess I’ll just have to be patient until my Intel NUC gets here.

[OT] For 199.00 € my son happily housed HASS on a blazing fast refurbished laptop w/ I7 + 8GB RAM + USB3 + 256GB Internal_SSD. Display, keyboard and UPS are free addons :wink:
Today paying 50% more one can find a Intel_I7 + 16GB RAM + 500 GB SSD refurbished notebook.

All true, but do not forget the power consumption considerations. Has anyone a clear view on this. E.g. raspi 4 4GB + SSD versus laptop of Intel NUC?


Depends on the NUC.
I am powering a mini PC with Pentium N5000 CPU with 4GB of RAM and 2 SSDs through a POE splitter (12W) which is lower power than a rPi4 can run on (it requires a 3A-5V to boot so 15W) and it performs 4-6X faster than a rPi4. The rPi4 is not power efficient at all. The idea that it consumes less power is just false perception. It is just cheap. If you want the same performance you can get yourself a compute stick with a cherry trail CPU which is powered with less than 5W, 1/4th of the rPi4. Cost is another story…


And you’ve downloaded the latest firmware from github and put it on the boot partition?

The pi 4 does not require 3A/5V it is advised.
It’s a assumption that your setup or a compute stick uses more equal or less than a pi4.
Unless there is proof of all of this(except the speed of a laptop or nuc)
Advising someone on just assumption isn’t really advise.

It is more than assumptions. It is based on what I have observed and tested. Thanks for your inputs though. The rPi4 has problems under load with 2A/5V and is prone to rebooting. Under load it benchmarks about the same as a compute stick which never consumes more than 7W. Likewise my mini PC is the N5000 never consumes more than 9W under stress with 2 SSDs, averaging 8W which the rPi4 easily hits with nothing attached with less than 1/4th the performance. The temperature from all the testing is also another data point. Under stress, my passively cooled N5000 never exceeds 65C. The same stress program on the rPi4 with an active cooler reaches 75C. The TDP of the intel chips are 3W for the Z and 7W for the N, the rPi’s is also 7W but power regulation on the rPi seems to be poorer causing power spikes/burst. At idle the bare rPi4 consumes ~3W, the mini PC with the SSD consumes 0.7W. Essentially the rPi consumes the same or in some situations a lot more power running much slower and generating a lot more heat, causing throttling which my mini PC never does. The rPi4 is cheaper by 25-30% when considering the case, cooling, power supply and storage to match the mini PC.

References which matches my observations:
And some benchmarks with links I collected when I had to make this decision, the N4100 is the same chip as the N5000, just a lower clock: