Finally! Raspberry PI 4 boot from SSD, no MicroSD required!

you should go with raspbian lite on the SSD… and then you should run supervised generic linux or HASS.core (docker)

@KingRichard You’re technically right, but I prefer not to invest my time on a (maybe) deprecated software, thus instead trying to trust and adapt to a (maybe) strategic solution :wink:

Go with HASS.core then…

I’m assuming that you’ve seen this : -

Now I’m not saying that this has anything to do with it, but it may help others if @fshelton79 and yourself could report back what your controllers are

Thanks In Advance

It gives you a hint. “USB-MSD boot requires newer software”. You need the newest *.dat and *.elf files from here:

Those need to be added to the boot partition, overwriting any of the old ones.

I’ve tested this, and while it starts booting from the USB stick, it stopped a few seconds later with no video output. I was using a beta RPI4 64-bit image however, so it might be my own fault that it didn’t get any further.


Good info.
Do you think that the Pi4 with this will boot from ANY ssd it can read ?
(considering the above James Chambers blog ?)
I’m just trying to get a handle on whether the new EFT boot method has changed the landscape.

Regardless - Anyone who is sucessfull in this can they please write up their method, the kit used, the adapter information, the link to where they bought it and what ssd
Many people will be in your debt.

Well for you guys who would like to try I wrote a short guide and maybe later I will add installing HASS.core into it. Anyway without further due

1 Like

Pretty much any standard Usb Mass Storage device should work, I believe.

@repvik I did similar tests by adding to the HassOS 1st SD partition (hassos-boot, where there is also a config.txt file) the bootloader files of an “upgraded” Raspbian image which boots correctly directly from SSD (no SD), but I messed something or that isn’t enough to complete the HassOS boot process.

Yesterday I also wrote a short guide for myself and who may be interested.
Feel free to cherry peek what you want.
Sorry I don’t have a blog, so it’s PDF :frowning:

EDIT: new working link.

1 Like

“Link no longer available” :cry:

Today I successfully used the aforementioned “boot from SD and run hassio_data on a SSD” technique which gives right now:

  • minimal wearing impact on the SSD;
  • great speed boost;
  • works on all RasPI models without any bootloader upgrade.

About this technique, instead of a dd + resize I prefer to do a full ext4 format of the SSD and use rsync (or some other logical copy method such as Midnight Commander) to copy the HassIO data files from the just renamed hassio-data-sd partition on the SD to the hassio-data partition on the SSD.

Just my 2 cents waiting for the HassOS native SSD boot on the RasPI4 :wink:


Updated, thanks.

For those of you having problems with your USB enclosure (uas error’s) ont he USB 3 ports, have a look at : [Raspberry Pi 4 USB mass storage beta]

I ran into UAS problems/erros when using an Icybox (JMicron JMS578 chipset). A replacement enclosure based on the AsMedia ASM1153E worked without a hitch.

It looks like U-Boot loads, but it probably can’t load its env-settings. Looking at boot.scr:

part start mmc ${devnum} 6 mmc_env
mmc dev ${devnum}
setenv loadbootstate " \
    echo 'loading env...'; \
    mmc read ${ramdisk_addr_r} ${mmc_env} 0x20; \
    env import -c ${ramdisk_addr_r} 0x4000;"

setenv storebootstate " \
    echo 'storing env...'; \
    env export -c -s 0x4000 ${ramdisk_addr_r} BOOT_ORDER BOOT_A_LEFT BOOT_B_LEFT; \
    mmc write ${ramdisk_addr_r} ${mmc_env} 0x20;"


I cannot load the PDF. I get issues with Chromium and FireFox.
Maybe consider another source like dropbox?

Thank you!

Chromium example …

Your connection is not private

Attackers might be trying to steal your information from (for example, passwords, messages, or credit cards). Learn more


ReloadHide advanced normally uses encryption to protect your information. When Chromium tried to connect to this time, the website sent back unusual and incorrect credentials. This may happen when an attacker is trying to pretend to be, or a Wi-Fi sign-in screen has interrupted the connection. Your information is still secure because Chromium stopped the connection before any data was exchanged.

You cannot visit right now because the website uses HSTS. Network errors and attacks are usually temporary, so this page will probably work later.

@stevevanhoyweghen and all, here is a Google Drive link, just verified on my Arch+Firefox box:

On the same Arch+Firefox box I still don’t have problems with the link:

1 Like

Thank you! Much appreciated.

WARNING: This EEPROM is buggy (I know it’s beta).
I’ve reverted to ‘Boot from MMC with root FS on USB’ after a total meltdown.

Everything was running smoothly (as regards Raspbian anyway) until I needed to reboot the Pi and it failed to come back up. Powering on with just an MMC failed and I didn’t get the four flashing green LEDs with no boot media. Diagnosis: corrupted, or buggy, EEPROM.

I restored using the procedure at: and reverted to the stable EEPROM, before configuring ‘Boot from MMC with rootfs on USB’

1 Like

It looks like we are ALL stuck in the same frigging place trying to boot HassOS from an SSD.

After multiple tries and finally a new SSD enclosure w/ USB 3.0, I’m also here during boot from USB SSD ( booting HassODS on the SD card in a USB reader works just fine) :

start4.elf is not compatible.

bummer. my Pi3 isn’t up the task of running home assistant any longer. and I’ve already burned up 2 SD cards. I was really hoping someone would have solved this by now. Guess I’ll just have to be patient until my Intel NUC gets here.