Finally! Raspberry PI 4 boot from SSD, no MicroSD required!

It is a Beelink S2 I bought about 2 years ago. Based on a gemini lake pentium N5000 CPU. The same one as on the review above but with the higher clock than the N4100.

Edit: here is one. $138 free shipping.

This thread is really off topic.

HassOS 5.x now has “USB mass storage device support”. Has anyone tried this yet? I don’t have a spare rPi 4 to test it on and am not 100% sure what all needs to be done to do it. My guess is that you need to update the EEPROM and load a fresh HassOS install using etcher to the USB drive (or SSD). But is that all?

I wrote a complete guide to install HassOS 5.1 onto a Pi 4 on a SSD, but it is written in German (maybe you can use Google Translate).

Here it is:über-usb-ange/?postID=90748#post90748


Thanks for the amazing guide! It worked more than smooth for me! :heart_eyes:

That is good to hear! Did you understand it without translating?
Maybe I can translate it when there is time and post it here somewhere.

I’m from Germany, so no need to translate. But Google translate or should do the job sufficiently for everyone who’s not speaking German.

Ok, that explains it. :slight_smile:

1 Like

for the newbs like myself, when editing the file you need to replace “critical” with “stable” and not add “-stable” to the single line… who would make that mistake anyway.

this guyyyyy.
otherwise the instructions worked great.

ps cant install 32bit 5.1, only 64bit version worked. online via router within 2 minutes.

Ah, thanks for this remark! I have changed it to be better understandable!

Maybe that’s why I wrote “64”. :slight_smile:

Great to hear!


only tried none 64 bit in fear that it may not allow some plug ins to work, since the official site has 32bit recommended for all installs. i just hoped it would have been possible. and to be able to tell others that it worked or not ;D

however atm i am struggling to change to mariadb. ive been using hassio for over a year and have yet to figure out how to get a local database to work. atleast 5 hours tonight alone. all suggestions are welcome.

This is what works for me. I use a secrets file so recorder is set to look there

purge_keep_days: 5
db_url: !secret mysql_pi4

My secrets link

mysql_pi4: mysql://hass:mypassword@core-mariadb/homeassistant

and my MariaDB config in the addon

  - homeassistant
  - username: hass
    host: homeassistant
    password: mypassword
  - username: hass
    host: homeassistant
    database: homeassistant

Is the guide for Hassio supervised?

It is for a complete HassOS on a Raspberry Pi.

Sorry, I really have problems with understanding the naming of the different version, but is that the supervised version?

I don’t know the naming also. It is the version complete with everything, the whole operating system for the Pi and the things for Home Assistant. There is nothing else than this on the Pi.

1 Like

I check it, it’s not the supervised version, you use sudo, that’s not an option on the supervised.
HASSIO supervised (or what ever) there is no SU commaned, all in runnig in a docker and everything is very limited. You only log into dockers not the real full system

I only use sudo in the Raspian installation on the SD card. That is only necessary to flash the newest bootloader into the Pi.
Afterwards you only have to attach the SSD with HassOS v5.1.

had a nightmare, logged into my RPI4 via port 22222
i wanted to get some help on the command to update from v5 to v5.1

instead it just installed the latest os v4x something

now i cant ssh or get back to my HA on the SSD.

any thoughts on the best way to roll back? or do i need to installed fresh again and then load up my nightly backup?

You just have to download the v 5.1 file and copy file on a USB stick.
Make sure you have the LABEL of the USB-drive named CONFIG, and then select import from USB in home-assistant within the Supervisor->System screen.