Finding the rtl_433_mqtt addon

I am running HA under virtualbox. If I go to terminal I get in to the HA OS but I cannot seem to find the rtl_433 files. Can someone please tell where they are located? I have tried find / “rtl_433” with nothing returned. The addons are installed and running. I need to update rtl_433_mqtt_auto_discovery with a fix for Govee water sensors.

In the rtl_433_mqtt_auto_discovery docker container (addons are just docker containers with some glue to be managed by supervisor)

Interesting. How do I access that? I see no evidence that docker is running.

Go to settings → addons

Add this repository

Install portainer from this repository

Then you can portainer to open a shell in the rtl_433_mqtt_auto_discovery docker container

I’m confused. I run HA under Virtualbox. There are no Docker containers. It runs fine. However, I need to change the addon for rtl_433_auto_discovery (it is running but does not understand govee devices and there is a fix).

HA OS is a minimal linux OS with a bunch of docker containers. You can say a thousand times there are no docker containers, but that does not make it true.

ps alx on linux shows no docker running. So how do I access these files?

Because if you use the Terminal & SSH add-on, you are in the Core container, not in the bare OS.
If you use the Advanced SSH and Web Terminal (from the community add-ons) with protection mode off, you can see more.

I go to settings->addons but don’t see how to add that addin.

I am probably just staring at it but here is what I have:

Screenshot 2023-09-12 at 1.27.46 PM

So close, refresh add-on store page, install portainer.

Thanks for your patience. Installed portainer , clicked start, spins for a few sec. and then Start comes back. I don’t see how to use this and given that I don’t see any indication that I’m running docker anywhere, unnless it is hidden, I don;t see how this helps with problem of finding the rtl_433_mqtt_auto_discovery addin that is already running.

The funny thing is that all of this works (rtl_433_mqtt_auto_discovery and numerous other addins. I have never knowingly installed Docker and all I start when I run HA is the Virtualbox VM instance. If I ssh to that, I don’t see docker or any of the addin files. Where are they hiding?

  • In the configuration panel of the addon, you can change the password
  • In the main page of the addon, disable “Protection mode”, then start the addon
  • Login (default name is admin, default password is homeassistant)
  • Click on Primary in the environement (at the center of the page)
  • Click on Containers in the left menu bar
  • Increase the number of items per page to see all your addons
  • Click on the symbol >_ next to the name of your selected addon to open the console page

Not sure why I would want to change the password as it would then break my rtl_433 command on the RPi. I don’t see “Protection mode” on the main page of the Addon. Is this what you consider the “main page”?

Or are you talking about the rtl_433 addin for running the rtl_sdr on the HA system, which I am not using?

OK, changed password, Started the Addin and went to localhost:9000, nothing there. Is that how it is accessed?

Either ‘open web-ui’ or first ‘show in sidebar’ and then click in sidebar