Fire a event when knx group message is received

Hi all,
as wrote on object, i want to fire an event (to catch from node-red) when a message with payload off is received on a group address of my knx bus.
the message is always off because the group is attached on all light of my house to switch off all them.
what i have tried to do was to put a binary_sensor like this:

  - platform: knx
    name: switch_off_all_button_knx
    state_address: '1/2/0'
    sync_state: false
      - hook: 'off'
          - event: event_switch_off_all_light
              state: on

this don’t works, i think the cause is that state not really change because the only message written on the group is off.
how i can do this job in right way?

There is a config option for the knx integration to always fire events: fire_event See
Maybe this does the job.

already tested but nothing.
hovewer, i was able to see the knx event:

    "event_type": "knx_event",
    "data": {
        "address": "1/2/0",
        "data": 0
    "origin": "LOCAL",
    "time_fired": "2019-10-22T18:30:43.984751+00:00",
    "context": {
        "id": "a9425ff1141d44e7af74262fc505d739",
        "parent_id": null,
        "user_id": null

you could also try reset_after with your binary_sensor.
The problem is that this sets the state to OFF again. You would need to invert your binary_sensor, but there is no configuration option for this. Maybe you can just use a logic in one of your knx devices to invert this and send it to a new GA.

for the moment is ok to use directly the event knx_event. in the next i will hope to use some ha standard way.

Are there any news on this topic? The behaviour of the binary sensor changed recently with the 0.116 release.

You can use a binary_sensor with ignore_internal_state = True if you don’t like the knx_event approach for whatever reason.

The binary sensor approach works, but I get two state changed events with off. ignore_internal_state = True ist set. Also, I set the sync_state= false, but it doesnt make a difference.
Does anyone knows why the event is getting fired a second time?

Does it help if you add context_timeout = 0? Or maybe even None instead of 0… you’ll have to try.

Hi, I don’t know how to use Home Assistant very well.

Can you guys tell me how to directly read the knx_event?

I understand that I have to set both fire_event: and fire_event_filter: but then what I have to do?

Depends on what you want to do with it. Maybe try to use it as a trigger in the automation builder.