Fire TV won’t connect

I have an Amazon Fire TV which I have been using for a while and has started having connection issues. It was originally using the AndroidTV integration, but since it was having errors that wouldn’t resolve, I deleted the integration to set it up using the FireTV integration.

It no longer will connect, it keeps failing under both the FireTV and AndroidTV integrations. So I tried to restore a backup from a few days ago thinking that would restore the integration, but it isn’t there anymore.

I have checked and ADB is turned on and verified the IP address was correct in the TV settings.

I have tried both integrations using the default settings, tried all 3 options for both (auto, androidtv, firetv) and every time I get the error “failed to connect”.

Any suggestions how to fix this? I use this for several automations.

Looks like the backup restore (I did a full restore, not a partial) has screwed up my system. :face_with_symbols_over_mouth::rage::face_with_symbols_over_mouth::rage:

Several of my add-ons will not start. There are missing required options for one, another will not start and gives no error message at all, just refuses to start.


Apparently I can get to the file editor. It has apparently replaced my terminal.

The entire system is a complete mess.